Shutting off while driving

Tiny
TBARB951
  • MEMBER
  • 2005 PONTIAC BONNEVILLE
  • V6
  • 2WD
  • AUTOMATIC
  • 144,785 MILES
The car shut off on the freeway at 70 MPH. Still had power but wouldn't start. Let sit a few minutes and started again.
Do you
have the same problem?
Yes
No
Thursday, March 17th, 2022 AT 9:30 AM

3 Replies

Tiny
JACOBANDNICKOLAS
  • EXPERT
Hi,

This sounds like it could be related to the crankshaft position sensor (CKP). When they start to fail, oftentimes they are affected by heat, and what you described can happen.

Do me a favor. Take a look through this link and let me know if it mirrors what you have experienced:

https://www.2carpros.com/articles/symptoms-of-a-bad-crankshaft-sensor

Let me know.

Take care,

Joe
Was this
answer
helpful?
Yes
No
Thursday, March 17th, 2022 AT 3:43 PM
Tiny
TBARB951
  • MEMBER
No, it doesn't stall at idle. Just driving at any speed. And when I try to start it right away it sounds like no fuel.
Was this
answer
helpful?
Yes
No
Friday, March 18th, 2022 AT 6:02 AM
Tiny
JACOBANDNICKOLAS
  • EXPERT
Hi,

Do me a favor. When this happens, see if it will restart using starting fluid. If it does and then stalls, we will know its fuel related. If there is no change, check for ignition spark.

Here is a link showing how it's done:

https://www.2carpros.com/articles/how-to-test-an-ignition-system

Let me know what you find.

Joe
Was this
answer
helpful?
Yes
No
Friday, March 18th, 2022 AT 5:54 PM

Please login or register to post a reply.

Sponsored links