High idle

Tiny
ALBERTAMABISCA
  • MEMBER
  • 1998 SATURN SL2
  • 4 CYL
  • 2WD
  • AUTOMATIC
  • 106,000 MILES
When started maintains 1900 rpm when driving and to a stop. After about 20 minutes or more it comes back down I took it to dealers they cleaned out throttle body and replace a throttle body switch it and still accelerates. What could I do to fix it myself?
Do you
have the same problem?
Yes
No
Monday, July 5th, 2010 AT 1:44 PM

120 Replies

Tiny
SATURNTECH9
  • EXPERT
Hello,

It soin slike they missed the IAC which sounds weak. Here are two guides that can help us fix this problem.

https://www.2carpros.com/articles/engine-idles-too-high

and

https://www.2carpros.com/articles/how-to-replace-an-idle-speed-control-motor-iac

Check out the diagrams (Below). Please run this test and get back to us.

Was this
answer
helpful?
Yes
No
Monday, July 5th, 2010 AT 4:05 PM
Tiny
ALBERTAMABISCA
  • MEMBER
They replaced idle air control valve, cleaned throttle body bore and cleaned injectors they did not mentioned any codes that poped up. Still had the same problem in the morning for. It wasnt cheap!Should I try replacing ects sensor? Thank you very much
Was this
answer
helpful?
Yes
No
Monday, July 5th, 2010 AT 7:46 PM
Tiny
SATURNTECH9
  • EXPERT
Lets run the codes to see what's coming up.

https://www.2carpros.com/articles/checking-a-service-engine-soon-or-check-engine-light-on-or-flashing

Please run down this guide and report back.
Was this
answer
helpful?
Yes
No
Tuesday, July 6th, 2010 AT 11:29 PM
Tiny
ALBERTAMABISCA
  • MEMBER
Well I replaced ects sensor now it idles a lot better in cold starts but now when driving sometimes it get stuck around 1900 rpm while in driving around and also when I come to a stop. And then it will run normal rpm. Its weird can you help me? What else I can do to try fix it? No codes. Thank you
Was this
answer
helpful?
Yes
No
Sunday, July 18th, 2010 AT 4:04 PM
Tiny
SATURNTECH9
  • EXPERT
It sounds more like the PCM is not working right I would try a rebuilt or used unit here is the location. Check out the diagrams (Below). Please let us know what you find. We are interested to see what it is.
Was this
answer
helpful?
Yes
No
Sunday, July 18th, 2010 AT 7:14 PM
Tiny
SHANNON_PRIV
  • MEMBER
Thank you for this post I had to get a used PCM cost me $70.00 worked great! I love this site.
Was this
answer
helpful?
Yes
No
Tuesday, January 22nd, 2019 AT 11:33 AM
Tiny
CHRISSIWATKINS
  • MEMBER
  • 1998 SATURN SL2
  • 6 CYL
  • 2WD
  • AUTOMATIC
  • 200,441 MILES
When my car is in drive it idles from about a one to a two, but when I go to park the car as soon as a put it in park it goes to a three maybe three and a half just sitting there and it is really killing my gas! Any suggestions?
Was this
answer
helpful?
Yes
No
Tuesday, January 22nd, 2019 AT 11:35 AM (Merged)
Tiny
LEGITIMATE007
  • EXPERT
I think you have a vacuum leak somewhere, and even a bad pcv valve, and a dirty throttlebody, lubricate the throttle linkage and clean the throttle body and plate, you may also want to check the idle air control valve, all of these can contribute to a high idle in park.
Was this
answer
helpful?
Yes
No
Tuesday, January 22nd, 2019 AT 11:35 AM (Merged)
Tiny
TINA1234
  • MEMBER
  • 1998 SATURN SL2
  • 4 CYL
  • 2WD
  • MANUAL
  • 223,597 MILES
I put my car on a diagnosistic test at Auto Zone, they said it was my EGR valve that went bad, well we replaced it and it still Ides real high, We don't know what else to do? Do you have anymore suggestions?
Was this
answer
helpful?
Yes
No
Tuesday, January 22nd, 2019 AT 11:35 AM (Merged)
Tiny
SATURNTECH9
  • EXPERT
Do u have any codes now what codes did u have before?How high does it idle and how often does it idle that high?
Was this
answer
helpful?
Yes
No
Tuesday, January 22nd, 2019 AT 11:35 AM (Merged)
Tiny
TINA1234
  • MEMBER
I have never had any codes the man at Auto Zone had the codes off the little machine, it idles up like to 4. And it mainly does it when irt is cold. After it warms up it is usually ok. Then you get in and cut it off and it does it again. What could it be? Gas is too high to waste on idleing problems.
Was this
answer
helpful?
Yes
No
Tuesday, January 22nd, 2019 AT 11:35 AM (Merged)
Tiny
SATURNTECH9
  • EXPERT
Yeah the codes off that little machine were the codes u had in ur cars computer thats why I asked what they were there any codes now. It helps me to figure out whats going on with ur car. Is ur engine light on?To go all the way up to four is really high at idle I would check for a vaccuum leak when its cold by letting it idle when its really high spray carb cleaner around the intake area vaccuum lines etc.I would also take off ur idle air control valve off and clean it. And check ur coolant temp sensorremove the connector check it for corrossion if the connector has it it needs to be replaced or cleaned. Check the sensor as well they crack and leak into the connector and read colder then actual temp. The sensor is screwed into the head below where the upper radiator hose goes on. The sensor is under 20 if u replace it make sure u get a brass tip the plastic tip ones crack. And see if u have any other codes from that little machine at autozone. From ur user name I take it ur a women and dont know much about cars judging from that answer u gave me that ur car doesnt have codes that little machine does lol. Nothing wrong with that just find someone that knows something about cars and pass this info on to them so they can help u fix ur car. Let me know what u find.
Was this
answer
helpful?
Yes
No
Tuesday, January 22nd, 2019 AT 11:35 AM (Merged)
Tiny
GARY RUSSELL
  • MEMBER
  • 1998 SATURN SL2
  • 4 CYL
  • 2WD
  • MANUAL
  • 89,678 MILES
My 1998 Saturn SL 2, Manual 5 speed is idling at 1100-1200 RPMs. The engine check light is NOT on and showing no codes. What is the problem and what should I do?
Was this
answer
helpful?
Yes
No
Tuesday, January 22nd, 2019 AT 11:35 AM (Merged)
Tiny
SATURNTECH9
  • EXPERT
So when the coolant temp is 195-222 degree's up it idles that high?
Was this
answer
helpful?
Yes
No
Tuesday, January 22nd, 2019 AT 11:35 AM (Merged)
Tiny
LILSPENCER722
  • MEMBER
  • 1998 SATURN SL2
  • 1.9L
  • 4 CYL
  • 2WD
  • AUTOMATIC
  • 160,000 MILES
My car runs great, except 1 thing ive noticed that I hope its a real problem, while on the interstate where the speed limit is 70, I run it 70-80 and the RPMs run 2500-3200. It sounds like its running high like it needs to switch another gear. Ive yet to think to listen to the gear changing to see if its missing top gear, but is that possible, but if its actually in its top gear doing that, is that bad, can that cause any more problems and/or how can that be fixed? I do travel allot. 2hrs to 6hr drives one way atleast twice a month. Thanks.
Was this
answer
helpful?
Yes
No
Tuesday, January 22nd, 2019 AT 11:35 AM (Merged)
Tiny
ASEMASTER6371
  • EXPERT
For a 4 cylinder it sounds normal. You should have shifts from 1-2, 2-3 and then converter clutch.

Roy
Was this
answer
helpful?
Yes
No
Tuesday, January 22nd, 2019 AT 11:35 AM (Merged)
Tiny
VEGASBJ247
  • MEMBER
  • 1995 SATURN SL2
  • 107,000 MILES
Hi, I have a 95 saturn sl-2 that has been having idle problems and stalling. The idle will rise to 2000 rpms or so when I start it then slowly come down to between 1000 and 1300. And sometimes the idle will be high and then out of nowhere the idle will drop to the normal 6-700 rpms. It also stalls occasionally. I have changed the iac, the tps, I cleaned the throttle body and the intake, I put a new map sensor on and still wont fix it. I brought the car to some guys house and he scanned it and the maps code came up but when I put it on it didn't do anything. Maybe he just had a cheap scanner. Do I need a new pcm? Or what could be the problem. Please help me, I dont know what else to do and the car is using more gas than necessary because of the high idle.
Was this
answer
helpful?
Yes
No
Tuesday, January 22nd, 2019 AT 11:35 AM (Merged)
Tiny
FIXITMR
  • MEMBER
Anyone check for intake gasket leaks?
Was this
answer
helpful?
Yes
No
Tuesday, January 22nd, 2019 AT 11:35 AM (Merged)
Tiny
VEGASBJ247
  • MEMBER
Yes they are fine
Was this
answer
helpful?
Yes
No
Tuesday, January 22nd, 2019 AT 11:35 AM (Merged)
Tiny
SATURNTECH9
  • EXPERT
Just to add to this one has anyone checked the coolant temp sensor the bottom one with two wires going to it?Its very common for them to fail and will cause high idles stall no starts all kinds of issues. Also inspect the inside of the connector if the terminals are green or blue instead of silver you will have to replace the connector also. Its real common for the sensors to crack and leak coolant into the connector. Alot of people over look a bad coolant temp sensor on those cars.
Was this
answer
helpful?
Yes
No
+4
Tuesday, January 22nd, 2019 AT 11:35 AM (Merged)

Please login or register to post a reply.

Recommended Guides