2001 Saturn SL1 problems on start and driving

Tiny
RJHELPME
  • MEMBER
  • 2001 SATURN SL1
Engine Performance problem
2001 Saturn SL1 4 cyl Front Wheel Drive Automatic 145k miles

2001 sl1, when starting wants to stall until you put the gas pedal to floor and then start it. Also when driving, temp gage will fluctuate from normal to absolutely cold, then back and forth. After driving, I put in park to turn off and it will rev to 3k rpms and stay there. Have consulted many different mechanics and no one can tell me what is wrong. Car has brand new starter.

When I am driving the car, it will rev high and that is when the temperature gage says it is cold, then when the temp gage goes to normal, the car will go to regular rpms. Anyone got ideas? Please help.
Do you
have the same problem?
Yes
No
Tuesday, May 4th, 2010 AT 10:48 AM

2 Replies

Tiny
SATURNTECH9
  • EXPERT


http://www.2carpros.com/forum/automotive_pictures/416332_2001_coolant_temp_sensor_4.jpg

it sounds like u have a bad coolant temp sensor i posted a diagram of where it is it justs screws into ur head.make sure ur engine is cold and u will loose some coolant while ur changing it.also make sure u buy a brass tipped sensor the plastic tipped ones crack.also inspect ur coolant temp sensor connector if its corroded replace it as well.there only like 10 for the sensor the connectors are a more.let me know how it works out for u but sounds like a bad coolant temp sensor and maybe a corroded connector as well.
Was this
answer
helpful?
Yes
No
Tuesday, May 4th, 2010 AT 12:29 PM
Tiny
RJHELPME
  • MEMBER
"Awesome! Thanks I will try this first, I was going to clean the Idle Air Control Valve, but I will try this first as you are a certified tech and more reliable source of info than the parts store would be. I will let you know how it goes and if it solves this problem."
Was this
answer
helpful?
Yes
No
Tuesday, May 4th, 2010 AT 1:27 PM

Please login or register to post a reply.

Recommended Guides