1996 SAAB 900 quirky electrical issue

Tiny
MACH1_70
  • MEMBER
  • 1996 SAAB 900
Electrical problem
1996 Saab 900 4 cyl Two Wheel Drive Automatic

i have been having some quirky electrical issues with my 96 saab 900 se turbo lately. When I try to start the car the "idiot" lights on the dash are real dim and even flicker. When the car starts the gauges do not work along with the dash illumination lights and the car lacks power going down the road and sometimes will stall at a light. The sids display will also dim and flicker and my radio will not work properly. I have noticed if when attempting to start I turn the key forward then back a few times I can eventually get the "idiot" lights to go bright like normal and then I can start the car and get full gauges with some illumination lights and full power going down the road. Even doing this I have had it a few times going down the road it all of a sudden loses the gauges and dash lights then has sluggish acceleration. Also, acts like it is going to stall at stop lights. I saw someone on another site with a similar issue replaced the i.C.E. Module and corrected their issue. I purchased one from a salvage yard that claimed it was pulled from a working car but it made no difference. I have no way to know if their information about the part was correct or if im having another issue. Any help would be appreciated. Thanks.
Do you
have the same problem?
Yes
No
Sunday, September 26th, 2010 AT 4:57 AM

1 Reply

Tiny
KHLOW2008
  • EXPERT
Hi mach1_70,

Thank you for the donation.

From the symptom description, it is possible you have a failing ignition switch.

It is not providing good contact and cycling the ignition switch on and off sometimes gets it to work correctly.

I would suggest getting it checked. Note if the switrch is hot to the touch after operating for a few minutes and look out for melted solders or heated connectors.
Was this
answer
helpful?
Yes
No
Sunday, September 26th, 2010 AT 8:14 AM

Please login or register to post a reply.

Recommended Guides