Rough idle

Tiny
BRADLEY WALKER
  • MEMBER
  • 2007 JAGUAR X-TYPE
  • 2.2L
  • TURBO
  • 2WD
  • MANUAL
  • 87,000 MILES
Hi there,

I recently bought the car listed above used. It is a diesel. The car had new injectors fitted and a service before I got it.
The car is very good except when the car starts from cold it idles very rough but once it warms up (two to three minutes) it is fine.

Can you provide any insight on this?

Thanks
Do you
have the same problem?
Yes
No
Saturday, August 11th, 2018 AT 1:10 PM

3 Replies

Tiny
KEN L
  • ADMIN
This sounds like an engine coolant sensor is not working right. But to be sure lets run the codes to see what comes up. Here is a guide to help us get started:

https://www.2carpros.com/articles/checking-a-service-engine-soon-or-check-engine-light-on-or-flashing

If this is a euro car the ALDL will be different.

Please run down this guide and report back.

Cheers, Ken

Was this
answer
helpful?
Yes
No
Monday, August 13th, 2018 AT 2:51 PM
Tiny
BRADLEY WALKER
  • MEMBER
Hi Ken, I have taken the car to me local garage and they plugged in a Snap On diagnostic scanner - no fault codes came up and there are no lights on my dashboard.
There was an injector leaking badly which I have since had replaced but the car is still idling rough.

Thanks
Was this
answer
helpful?
Yes
No
Thursday, August 23rd, 2018 AT 1:29 PM
Tiny
KEN L
  • ADMIN
It sounds like you have a vacuum leak which will cause the issue you have described. Here is a guide that should help find it:

https://www.2carpros.com/articles/how-to-use-an-engine-vacuum-gauge

Please run down this guide and report back.

Cheers, Ken
Was this
answer
helpful?
Yes
No
Thursday, August 23rd, 2018 AT 8:16 PM

Please login or register to post a reply.

Sponsored links