Revs Bouncing

Tiny
JCHILTON1995
  • MEMBER
  • 2015 HYUNDAI I30
  • 1.6L
  • 2WD
  • MANUAL
  • 15,000 MILES
My 1.6 diesel I30 revs are bouncing while stationary at traffic lights etc, the car is barely 1 year old with no fault codes being found at dealer. I Notice a slight judder when driving when I lift foot off accelerator the juddering can last for 20 seconds if I dont re-apply gas. The Cars due back in to dealer in 2 week looking for some advise before its goes back in for another check.

Thanks
Do you
have the same problem?
Yes
No
Thursday, September 8th, 2016 AT 5:14 AM

9 Replies

Tiny
KEN
  • ADMIN
Is the check engine light on? I would scan for codes before it goes in so you get an idea what you are in for, here is a guide that will help you.

https://www.2carpros.com/articles/checking-a-service-engine-soon-or-check-engine-light-on-or-flashing

Please let us know what you find so it will help others.

Best, Ken

Was this
answer
helpful?
Yes
No
Wednesday, September 14th, 2016 AT 6:43 PM
Tiny
JCHILTON1995
  • MEMBER
Thanks for that Ken, I have had the codes checked no codes at all ! Check engine light is not on either.
Was this
answer
helpful?
Yes
No
Thursday, September 15th, 2016 AT 4:15 AM
Tiny
KEN
  • ADMIN
It sounds like the injector pump is bad which is a common problem with theses cars, the dealer will need to check this.

Please let us know what you find out from the dealer.

Best, Ken
Was this
answer
helpful?
Yes
No
Thursday, September 15th, 2016 AT 12:20 PM
Tiny
JCHILTON1995
  • MEMBER
Thanks Ken cars due in on 23rd will update then.

Thanks
Was this
answer
helpful?
Yes
No
Friday, September 16th, 2016 AT 1:28 AM
Tiny
KEN
  • ADMIN
Please let us know what you find so it will help others.

Best, Ken
Was this
answer
helpful?
Yes
No
Friday, September 16th, 2016 AT 6:57 PM
Tiny
JCHILTON1995
  • MEMBER
Hello my back on this thread, still no joy Hyundai cannot get the fault codes and have handed back with no fault found I've tried to attach a video of the revs jumping.
Was this
answer
helpful?
Yes
No
Thursday, November 3rd, 2016 AT 11:51 AM
Tiny
KEN
  • ADMIN
Upload the video to youtube and then give us the link.
Was this
answer
helpful?
Yes
No
Thursday, November 3rd, 2016 AT 11:54 AM
Tiny
JCHILTON1995
  • MEMBER
Hello this should be it https://m.youtube.com/watch?v=uJiY-Uy2Y6k
Was this
answer
helpful?
Yes
No
Thursday, November 3rd, 2016 AT 12:11 PM
Tiny
KEN
  • ADMIN
Nice work, It looks like the computer is having a hard time stabilizing the idle speed. Check for vacuum leaks I would also clean the MAF sensor. Here is some guides to help with both.

https://www.2carpros.com/articles/how-to-use-an-engine-vacuum-gauge

and

https://www.2carpros.com/articles/mass-air-flow-service

Please let me know,

Ken

Was this
answer
helpful?
Yes
No
Thursday, November 3rd, 2016 AT 1:15 PM

Please login or register to post a reply.

Recommended Guides