Readings and signals "low oil pressure", "engine power reduced stop engine"

Tiny
KAYJONES
  • MEMBER
  • 2007 CHEVROLET IMPALA
  • 173,000 MILES
I purchased the car and the ride home no displays were on, however I didn't try to drive again until I got my plates. I probably drove for 15 minutes before dash started reading "low oil pressure", "engine power reduced stop engine". I then stopped at nearest store and went in came out it started but seconds later shut off I tried to start it and it started reading "starting disabled service throttle". I just recently replaced the oil pressure sensor do I haven't seen the low oil pressure pop up again. But, it won't start still and I still see readings for "engine power reduced" and "starting disabled service throttle". What should my next steps be and what exactly could be causing this issue? Google is giving me so many different answers and has utterly confused me.
Do you
have the same problem?
Yes
No
Sunday, July 14th, 2019 AT 4:26 PM

1 Reply

Tiny
KEN L
  • ADMIN
Hello,

This sounds like the car is in limp mode due to a dirt throttle bore which is common with this mileage. here is a guide to help fix it:

https://www.2carpros.com/articles/reduced-power-limp-mode

We should run the codes as well.

https://www.2carpros.com/articles/checking-a-service-engine-soon-or-check-engine-light-on-or-flashing

Please run down these guides and report back.

Was this
answer
helpful?
Yes
No
Monday, July 15th, 2019 AT 5:47 PM

Please login or register to post a reply.

Sponsored links