Randomly shut off after a two hour drive

Tiny
DARSIMON321
  • MEMBER
  • 2000 MITSUBISHI ECLIPSE
  • 3.0L
  • V6
  • 2WD
  • MANUAL
  • 137,000 MILES
Went for a day trip to go hiking, drove the car all day no problem, made the hour trek back home and the car shut off in front of my garage. Did not stall it, it was in neutral and I was in the process of pulling the e-brake then it shut off, as if I had stalled it. Just finished replacing crank sensor because it had very weak spark, have checked both fuse boxes and see no blown fuses. I can smell fuel so I believe that's working fine. Is not showing any codes.
Do you
have the same problem?
Yes
No
Friday, May 21st, 2021 AT 11:57 AM

1 Reply

Tiny
KASEKENNY1
  • EXPERT
There are a number of things that can cause this but we need to start with finding out how many times it does this. Did it just do this one time or can you get it to do it over and over?

Here are some guides that will help with this:

https://www.2carpros.com/articles/engine-stalls

https://www.2carpros.com/articles/stall-at-idle

Also, after it stalled could you restart it with no issues?

Or did it shut off and just not restart? If this is the case then we need to run though a number of things to find out what we don't have, starting with spark due to the recent crank sensor change.

https://www.2carpros.com/articles/car-cranks-but-wont-start

If it is just cranking and not starting then I would put money on a crank sensor issue so let's pull a plug wire and hold it against the block and crank the engine to see if you have any spark.

Let us know about this info and we can go from there. Thanks
Was this
answer
helpful?
Yes
No
Saturday, May 22nd, 2021 AT 5:48 PM

Please login or register to post a reply.

Sponsored links