Service engine soon light, slip light, TCS off light, tire pressure monitoring system light are all on

Tiny
FRANKLIN7710
  • MEMBER
  • 2005 NISSAN QUEST
  • 3.5L
  • V6
  • 2WD
  • AUTOMATIC
  • 180,000 MILES
The above-listed lights have turned on. Also, the display that shows the odometer and the fuel gauge is just blank lit up white. Also, when I try to crank the vehicle, it hesitates to start, when I go to drive if it is in d (drive) it doesn't want to change gears, I have to put it in (low gear) when I first take off then I can shift it into d (drive) but it will not go above possibly third gear or into overdrive. When I plug in a code reader it was throwing up 1 code (crankshaft position sensor bank 1) I changed those sensors and it is still having the same issue. Do you have any advice on what I could do to fix the vehicle or does the Vehicle need a new transmission?
Do you
have the same problem?
Yes
No
Saturday, March 26th, 2022 AT 6:59 PM

1 Reply

Tiny
JACOBANDNICKOLAS
  • EXPERT
Hi,

I don't feel it is a transmission-related issue. I feel the transmission is being affected by an electrical issue.

In this case, you really need to scan the can-bus system. CAN stands for controller area network. Basically, all the different computers and modules are tied together via a few wires. This type of scan will identify a code regardless of the module storing it. A basic scanner won't do this.

Here is a link showing how it is done:

https://www.2carpros.com/articles/can-scan-controller-area-network-easy

Because there are so many different issues, this should be done.

Let me know if you can get this done. Also, let me know the code or codes that were originally retrieved related to the crankshaft position sensor.

Take care,

Joe
Was this
answer
helpful?
Yes
No
Sunday, March 27th, 2022 AT 2:58 PM

Please login or register to post a reply.

Sponsored links