Problem with transmission makes a wee sound?

Tiny
AUSTINO
  • MEMBER
  • 2003 JAGUAR S-TYPE
  • V6
  • 2WD
  • AUTOMATIC
  • 67,000 MILES
Good afternoon,
When ever time the transmission changes, it makes a wee sound, and this sound continues while driving. Also, whenever time the vehicle stops in the traffic and the vehicle wants to move again, sometimes the vehicle moves backward instead of going forward. As a result, in order for me to get the vehicle moving forward again, I have to switch the vehicle off and put it in park, then when I restart the vehicle, it will move forward again. In addition, sometimes the car revs and does not move while driving in traffic. Do you know what cause these problems? Can you tell me where the transmission oil can be refilled from? And how do you know when the transmission has in the correct amount of oil?

Thank you in advance for a speedy response.
Thursday, May 2nd, 2024 AT 4:46 PM

2 Replies

Tiny
KEN L
  • MASTER CERTIFIED MECHANIC
  • 44,209 POSTS
It sounds like the mode switch inside the shifter has gone bad, but we should run the codes to see if any are stored.

This guide can help:

https://www.2carpros.com/articles/checking-a-service-engine-soon-or-check-engine-light-on-or-flashing

Here are the transmission wiring diagrams so you can see how the system works, and I have included how to change or test the mode switch. Check out the images (below). Please upload pictures or videos in your response to any problems so we can see what to help you with.

Was this
answer
helpful?
Yes
No
+1
Friday, May 3rd, 2024 AT 12:35 PM
Tiny
AUSTINO
  • MEMBER
  • 199 POSTS
Thank you. I will check and keep you updated on what I find.
Was this
answer
helpful?
Yes
No
Friday, May 3rd, 2024 AT 5:27 PM

Please login or register to post a reply.

Sponsored links