1998 Pontiac Grand Prix Shuts Off While Driving

Tiny
MACKY808
  • MEMBER
  • 1998 PONTIAC GRAND PRIX
  • 6 CYL
  • FWD
  • AUTOMATIC
  • 166,000 MILES
I have a 98 Pontiac GTP Supercharge 3.8 that shuts off after running anywhere from 30-60 minutes. The first time it happened I had let it gotten low on fuel and when I filled up, jumped on the freeway, it died while in motion. It started after about 15 minutes and I thought it was trash in the line. Since then it does the same thing every time, even if I'm parked and let it run. So, I changed the fuel pump, fuel filter, taken out and cleaned the MAF, TPS, Idle Sensor. Once I did this it ran a little longer while driving but eventually shut down. At first it would start after 15 min then, 45 min and now it has to cool all the way down before it will restart. Firestone put it on the diagnostic and found "No Codes". My friend used his hand held diagnostic and found "No Codes". Please help, I need a car to find work.
Do you
have the same problem?
Yes
No
Tuesday, August 4th, 2009 AT 3:34 AM

8 Replies

Tiny
MMPRINCE4000
  • EXPERT
Remove ign. Module and have it tested at most autoparts stores.
Was this
answer
helpful?
Yes
No
Tuesday, August 4th, 2009 AT 12:21 PM
Tiny
MACKY808
  • MEMBER
Thanks, I'll ask to see which autoparts will test it. Someone else suggested it was the Ign. Mod. Too.
Mahalo!
Was this
answer
helpful?
Yes
No
Wednesday, August 5th, 2009 AT 5:38 AM
Tiny
MMPRINCE4000
  • EXPERT
It is classic symptom of a module. Have them run the test twice to make sure the module gets hot enough.
Was this
answer
helpful?
Yes
No
Wednesday, August 5th, 2009 AT 7:31 AM
Tiny
MACKY808
  • MEMBER
Thanks! - I'm here in Hawaii and having trouble finding a place that does the check. I've tried Napa, Checkers, Redline. Might have to go to private repair shop. But, as it stand I'm almost willing to just buy another one if I can't get this one tested. - Mahalo -
Was this
answer
helpful?
Yes
No
Thursday, August 6th, 2009 AT 6:40 PM
Tiny
MMPRINCE4000
  • EXPERT
Advance and Oreilly's check them.
Was this
answer
helpful?
Yes
No
Friday, August 7th, 2009 AT 8:05 AM
Tiny
MACKY808
  • MEMBER
Thanks! - Found one on amazon. Com for a really good price. Mahalo!
Was this
answer
helpful?
Yes
No
Friday, August 7th, 2009 AT 7:13 PM
Tiny
MMPRINCE4000
  • EXPERT
Good News.
Was this
answer
helpful?
Yes
No
Saturday, August 8th, 2009 AT 9:10 AM
Tiny
MACKY808
  • MEMBER
Well, I found a new ign. Mod, put it on and it ran for a while but, it did the same thing. New thought for now is maybe it's the crank position sensor or throttle position sensor. Any ideas? Remember it'll run perfectly fine for 30-45 min and then the 'TCS Off' light comes on and if I step on the pedal it dies and won't start till the car cools down. No coolant problems though, temp only reaches 190. Pls let me know.
Was this
answer
helpful?
Yes
No
Sunday, August 9th, 2009 AT 8:33 PM

Please login or register to post a reply.

Related Engine Stall While Driving Content

Recommended Guides