1999 Pontiac Grand Am Idle problems

Tiny
TROY0007
  • MEMBER
  • 1999 PONTIAC GRAND AM
  • 4 CYL
  • FWD
  • AUTOMATIC
  • 210,000 MILES
I have a 1999 pontiac grand am se 2.4l 4c engine it has about 210000miles on it, a few days when I am driving between 10 and 40mph when I take my foot of the gas the RPMs will jump back and forth from 600rpms to 1300rpms and when I am in idle the engine shakes (idle speed is around 600to 700), I have changed all the sensors on the throttle body(MAP, IAC, Throttle Position Sensor ) Please Help.
Do you
have the same problem?
Yes
No
Saturday, March 21st, 2009 AT 9:47 AM

4 Replies

Tiny
JDL
  • EXPERT
Did you check sensor circuits, before you replaced anything? Did you take the throttle-body off and give it a good cleaning? You may have a vacuum leak somewhere? I've seen vacuum leaks and/or misfiring cylinders cause a lousy idle.

Are there any codes? Some of the national brand autostores will check codes for free.
Was this
answer
helpful?
Yes
No
Saturday, March 21st, 2009 AT 10:08 AM
Tiny
TROY0007
  • MEMBER
It has error code 507, all the sensor circuits are fine.

Could this be a leak in the power stearing?
Was this
answer
helpful?
Yes
No
Saturday, March 21st, 2009 AT 10:15 AM
Tiny
LANCCARP
  • MEMBER
I have the same car as you do and my car use to shake when I was a drive thrus, or at red lights and it ended up being a simple vacuum leak. It would even shut off sometimes! SCARY! I got it fixed like 3 years ago and have had no problems! Hope this helps!
Was this
answer
helpful?
Yes
No
Saturday, April 18th, 2009 AT 3:40 PM
Tiny
JDL
  • EXPERT
It has error code 507, all the sensor circuits are fine.

Could this be a leak in the power stearing?[/Quote:113ede3018]

Hello, the p0507 shows to be the idle-air system.
Was this
answer
helpful?
Yes
No
Wednesday, April 22nd, 2009 AT 9:32 AM

Please login or register to post a reply.

Recommended Guides