1992 Pontiac Bonneville car problems

Tiny
ROBERT DUNCAN 2
  • MEMBER
  • 1992 PONTIAC BONNEVILLE
  • 6 CYL
  • 2WD
  • AUTOMATIC
  • 260,000 MILES
I have a 1992 pontiac bonneville se 3.8 liter. Question is while cold the car will start fine but when the car warms up and the car is turned off it will not start back up. When it cools down it will start back up. Ive had the ignition control module checked with passing results. What could be the reason for this action?The check engine light is NOT on so im puzzled. Please help
Do you
have the same problem?
Yes
No
Saturday, September 27th, 2008 AT 7:03 PM

6 Replies

Tiny
JJHOHNE2
  • MEMBER
If you can do a diagnostics on your car it can probrably figure it out. Next to the fuse box theres something that looks like it has a bunch of holes. If you use a paper clip to trip(or get what will look like a key from autozone) it by puttin one end in the hole on the top right and the one next to it. Turn the key forward but not on. Count the flashes. The first set is going to be tens the second ones. It will automaticly flash ones then twice. Thats twelve. Its programed to do that.
Was this
answer
helpful?
Yes
No
Saturday, September 27th, 2008 AT 9:39 PM
Tiny
ROBERT DUNCAN 2
  • MEMBER
I did what you recommended and it gave me the response of first 12 and then what I gatherded was the code 58 I called the autoparts store and they referred to oxygen sensor and camshaft sensor.I purchased the items and put the cam. Sensor on but with no diff. Result.I cant seem to get the oxygen sensor off I guess because its torqued to tightly. Any other suggestions?Thanks for your time
Was this
answer
helpful?
Yes
No
Sunday, September 28th, 2008 AT 11:46 AM
Tiny
JJHOHNE2
  • MEMBER
Yeah this is kind of funny because I have the same code coming up in my car. Plus I have another code that refers to the cam sensor circuit the only difference is that my car still runs. Does your car stall or do you just shut it off and it wont start up. Mine would just shut off as I was driving and the engine light would come on. That was my crankshaft sensor. I dont know much about cars but I tend to know alot when my car starts screwin up. I'll do what I can to help though.
Was this
answer
helpful?
Yes
No
Sunday, September 28th, 2008 AT 8:01 PM
Tiny
ROBERT DUNCAN 2
  • MEMBER
When my car is running, it runs great like no problems at all. Just when it starts to heat up or when it gets hot and say I run into the store if I was to come back out and start my car it wouldnt completely start up, only turn over. Its the wierdest thing but im not willing to keep spending unnecessary money when its not fixing the problem. Any other suggestions I am willing to check out. Also my check engine light has never came on due to a problem and the light does work. So? Also, it hasnt stalled up until now it runs fine just when I turn it off
Was this
answer
helpful?
Yes
No
Monday, September 29th, 2008 AT 6:42 PM
Tiny
JJHOHNE2
  • MEMBER
The only other thing you could do is to replace the Oxygen sensor since that code refers to that to. I know my dad had to get his replace because his van would stall. I think it cost him like 70 bucks to have someone do it, but he said that it was easy to do. Sorry I couldnt be of more help.
Was this
answer
helpful?
Yes
No
Wednesday, October 1st, 2008 AT 11:23 AM
Tiny
ROBERT DUNCAN 2
  • MEMBER
I took it to my mechanic and had it fixed. Turns out it was the crankshaft sensor and the harmonic balancer I still replaced the spark plugs and wires along with the oxygen sensor. Its running fine at this point so thanks for all the help
Was this
answer
helpful?
Yes
No
Wednesday, October 1st, 2008 AT 6:23 PM

Please login or register to post a reply.

Recommended Guides