1993 Plymouth Acclaim not working

  • 4 CYL
  • FWD
  • 86,000 MILES
A/C worked fine until recently. W/ A/C on compressor runs sporatically, no cold air, constant squeking/squelling sound from compressor. Tried A/C repair kit with R134a and appropriate fittings. Compressor would not take charge. Label on evaporator states compatible with R12 or R134a.
Do you
have the same problem?
Monday, May 10th, 2010 AT 10:59 AM

1 Reply

Hi gharney. Welcome to the forum. The evaporator is hidden inside the heater box under the dash. I suspect you mean the condenser next to the radiator, not that it matters. That sticker means it will work with either refrigerant, not that you can put either one in. Chances are the car came with R-12. (My '93 Dynasty has R-12 too. It was the last year they used it). However, I retrofitted my '88 Grand Caravan to R-134 by replacing the oil in the compressor and installing new fittings. That's all that was needed, and it worked fine. If your system was retrofitted in the past, there will be adapter fittings on the ports that will only allow the use of R-134. If you managed to add the wrong refrigerant, it will not be compatible with the oil circulating in the system and with the old refrigerant remaining in the system.

Assuming you used the correct stuff, ("appropriate fittings"), place the can upright in a pot of hot water. The refrigerant will go in in about 30 seconds.

I think there may a different problem though. Cycling on for a very short period of time is indeed a sign of low charge, but the compressor clutch or belt should not be squealing. Check the belt tension, and watch the plate on the front of the compressor clutch. Often you can see it stall when the clutch is slipping. If that's what is happening, first try swapping the compressor relay with one of the other ones in the fuse box under the hood. Pitted contacts will cause a voltage drop and the clutch coil will have low voltage and a weak magnetic field. Measure the voltage across the two wires in the clutch electrical connector when it engages. It must have full battery voltage. If the voltage is low, besides the pitted relay contacts, look for corrosion on the pins inside other electrical connectors.

Was this
Monday, May 10th, 2010 AT 2:28 PM

Please login or register to post a reply.

Recommended Guides