Parking/running lights remain on while vehicle is off

Tiny
OGEYORGENSEN
  • MEMBER
  • 1994 FORD E-SERIES VAN
  • 5.8L
  • V8
  • 2WD
  • AUTOMATIC
  • 55,000 MILES
Hi I drive the vehicle listed above e-350, 351 Windsor v8 (5.8L) ~55,000 mi, it is a Tioga Montera Camper.

I've had persistent issues with the parking/running lights remain on unless:

I. The positive or negative power terminal is disconnected.

II. Fuse "K" in the Power Distribution Box labeled Trailer tow running and backup lamps, 20 Amp is removed.

With the key out of the ignition in the off position the lights remained on when:

I. Headlight switch is undone.

II. All fuses are removed from below the steering column.

Any advice about what could be wrong is greatly appreciated.
Do you
have the same problem?
Yes
No
Wednesday, May 13th, 2020 AT 12:03 PM

1 Reply

Tiny
JACOBANDNICKOLAS
  • EXPERT
Hi,

Since this is a camper, I am not going to have the wiring schematics for it other than what Ford provided. Looking at the wiring schematic I can not find fuse K. If you look at the first pic I attached, I highlighted the wiring for the parking lights. If you note, the green wire goes to the trailer camper circuit, which is where I believe you found fuse K. However, I can find fuse J, P, N, M but no K. See the remaining two pics that show the entire schematic related to the trailer / camper circuit.

Now, since the light stay on when the headlight switch is disconnected, that tells me there is a short to power. The only way for that short to turn on the lights would mean it is after fuse K (which I can't find). It may have been something added by the body company.

Let me know if you see any of the fuses indicated in the schematic.

Joe
Was this
answer
helpful?
Yes
No
Wednesday, May 13th, 2020 AT 10:00 PM

Please login or register to post a reply.

Sponsored links