1991 Oldmobile Cutlass Supreme Signal Probelms

Tiny
HONDA_MASTER
  • MEMBER
  • 1991 OLDSMOBILE
I have a 1991 Oldsmobile Cutlass Supreme with 183,000 miles on it. I've been having problems with my turn signals. When I go to turn either right or left the signal blinks very slowly. I sometimes have to hold it in a certain spot for it to work at all. Then after I was messing around with it for awhile I started to smell something electrical burning, so I stopped and shut the ignition off. Any ideas on what the problem could be. Any help would be very much appreciated. Thanks
Do you
have the same problem?
Yes
No
Monday, October 1st, 2007 AT 7:50 PM

3 Replies

Tiny
BMRFIXIT
  • EXPERT
++++

YOUR SIGNAL SWITCH is no good
You need it replaced
You have to remove the steering wheel and plate under it to reach the switch.
Good luck
Was this
answer
helpful?
Yes
No
Monday, October 1st, 2007 AT 7:57 PM
Tiny
HONDA_MASTER
  • MEMBER
++++

YOUR SIGNAL SWITCH is no good
You need it replaced
You have to remove the steering wheel and plate under it to reach the switch.
Good luck[/quote:128eaa7264]

Do you think I might have made things worse by messing around with it? The burning electrical smell didn't seem to good.
Was this
answer
helpful?
Yes
No
Monday, October 1st, 2007 AT 8:07 PM
Tiny
BMRFIXIT
  • EXPERT
++++

YOUR SIGNAL SWITCH is no good
You need it replaced
You have to remove the steering wheel and plate under it to reach the switch.
Good luck[/quote:14cee1516e]

Do you think I might have made things worse by messing around with it? The burning electrical smell didn't seem to good.[/Quote:14cee1516e]

no

they become loose on the inside

have it replace asap!
Was this
answer
helpful?
Yes
No
Tuesday, October 2nd, 2007 AT 6:11 PM

Please login or register to post a reply.

Recommended Guides