2001 Oldsmobile Intrigue metallic noise

Tiny
SPOONMAN80
  • MEMBER
  • 2001 OLDSMOBILE INTRIGUE
  • 6 CYL
  • FWD
  • AUTOMATIC
  • 120,000 MILES
I bought this car used from a friend about 2 years ago and it has been making a strange metal on metal rubbing noise from the front suspension under acceleration from a dead stop, I took it to a dealership mechanic and they said I had 1 control arm bushing that was completly worn out, would that be the reason for the noise, or would it be from the front struts or steering rack
Do you
have the same problem?
Yes
No
Wednesday, July 15th, 2009 AT 10:52 PM

3 Replies

Tiny
MHPAUTOS
  • EXPERT
Hi there,

I would get the bush replaced and have the rest check, they will have to do an alignment as well, start here.

Mark (mhpautos)
Was this
answer
helpful?
Yes
No
Wednesday, July 15th, 2009 AT 11:29 PM
Tiny
SPOONMAN80
  • MEMBER
Just replaced the control arm bushings on both sides today. Along with both sway bar links. The car handles ALOT better now and the brake wobble I had seems to have gone away, feels alot more solid up front. But, I still hear that noise under acceleration. Im wondering if its those rusty front struts even tho they dont show any other signs of being bad.
Was this
answer
helpful?
Yes
No
Tuesday, July 28th, 2009 AT 9:54 PM
Tiny
MHPAUTOS
  • EXPERT
Hi there, try giving the struts a liberal dose of spray on lube (WD40 or similar) see if that stops the noise.

Mark (mhpautos)
Was this
answer
helpful?
Yes
No
Tuesday, July 28th, 2009 AT 10:31 PM

Please login or register to post a reply.

Recommended Guides