1988 Oldsmobile Delta 88 car shutting off after running for

Tiny
JHITT77
  • MEMBER
  • 1988 OLDSMOBILE DELTA 88
  • 6 CYL
  • FWD
  • AUTOMATIC
  • 150,000 MILES
My 88 olds delta 88 royal has began shutting off after running for a while. Once the engine heats up it shuts off like the key was shut off, and then will not fire over for several hours. I have replaced the brain, both the cam and crank sensor, and the top electronic distributor pack( the part with the plug wires ). Still does it, we had the ignition module, I think thats the name, tested and they said it was good, im lost any help will be very appriciated. Thx
Do you
have the same problem?
Yes
No
Thursday, March 4th, 2010 AT 5:30 PM

8 Replies

Tiny
JACOBANDNICKOLAS
  • EXPERT
When it doesn't start, have you checked if it is getting spark and fuel to the engine?
Was this
answer
helpful?
Yes
No
Monday, April 12th, 2010 AT 9:47 PM
Tiny
JHITT77
  • MEMBER
The car is still doing the same thing, it is getting fuel, but no spark when it happens. With brain, distributor, cam crank and now comp under distributor replace, still no spark after it stalls. Now I did find out that when the crank sensor was replaced they didnt replace the magnet, and its missing. They say the magnet wont cause this prob at all. Also had all ignition wires traced and all are in good condition. Im soooo lost.
Was this
answer
helpful?
Yes
No
Tuesday, April 13th, 2010 AT 5:15 AM
Tiny
JACOBANDNICKOLAS
  • EXPERT
Have they replaced the ignition module?
Was this
answer
helpful?
Yes
No
Tuesday, April 13th, 2010 AT 7:00 AM
Tiny
JHITT77
  • MEMBER
We replaced the comp underneath the electronic distributer
Was this
answer
helpful?
Yes
No
Tuesday, April 13th, 2010 AT 10:26 AM
Tiny
JACOBANDNICKOLAS
  • EXPERT
The ignition module is in the distributor.
Was this
answer
helpful?
Yes
No
Tuesday, April 13th, 2010 AT 12:15 PM
Tiny
JHITT77
  • MEMBER
I know the mechanic said they replaced the ignition moduel, and the coil pack.
Was this
answer
helpful?
Yes
No
Tuesday, April 13th, 2010 AT 4:53 PM
Tiny
JACOBANDNICKOLAS
  • EXPERT
The only thing left is the PCM which you said was replaced. The reason I kept asking about the ignition module is because what you described is what they do before they go out completely. The original post mentioned they tested it and it was good. It may be breaking down when it gets hot. Other than that, one of the new parts you replaced has to be bad. You've done it all. Has the check engine light come on?
Was this
answer
helpful?
Yes
No
Tuesday, April 13th, 2010 AT 9:41 PM
Tiny
JHITT77
  • MEMBER
There is a service engin soon light on. Is the the check engine? It has been on since we bought the car. Havent seen check engin tho. I had asked about the magnet inside the timing cover, you never mentioned that one, it wasnt replaced
my wife read something about some sort of a computer by the exaust manafold, do you know anything about that? I think its the one under the coil pack distributer
Was this
answer
helpful?
Yes
No
Wednesday, April 14th, 2010 AT 7:16 AM

Please login or register to post a reply.

Recommended Guides