Radiator fan not working properly

Tiny
MICHAEL BLANDING
  • MEMBER
  • 1999 OLDSMOBILE ALERO
  • 2.4L
  • 4 CYL
  • 4WD
  • AUTOMATIC
  • 233,645 MILES
My radiator fan only comes on with the air conditioner being on it doesn't come on by itself and all the relays are working fine.
Do you
have the same problem?
Yes
No
Saturday, September 19th, 2020 AT 4:06 PM

2 Replies

Tiny
JACOBANDNICKOLAS
  • EXPERT
Hi,

How were the relays tested? Also, what temperature does the engine reach or is it overheating?

Here is a link that explains how the system is designed to work. Take a look through it and see if something stands out with your vehicle. Also, let me know if the temperature gauge in the vehicle is working.

https://www.2carpros.com/articles/how-an-electric-cooling-fan-works

Let me know.

Joe
Was this
answer
helpful?
Yes
No
Saturday, September 19th, 2020 AT 6:27 PM
Tiny
KASEKENNY1
  • EXPERT
I assume the vehicle is overheating? Do both fans come on when the A/C is on?

Also, we need to check power coming from the PCM when the engine is at operating temp. This could be as simple as a temperature sensor or more complicated like a PCM.

However, let's start with checking power on the command terminal of the relay. Check this by removing the fan control relay one and two then put the positive lead of the positive battery post and then the black lead on the terminal from the relay when the fans should be on. If there is 12 volts then the PCM is grounding the relay and the fans should be on.

Let's start there and see what we turn up.
Was this
answer
helpful?
Yes
No
Saturday, September 19th, 2020 AT 6:30 PM

Please login or register to post a reply.

Sponsored links