No spark condition

Tiny
JOHN KLAPP
  • MEMBER
  • 2005 CHEVROLET SILVERADO
  • 4.3L
  • V6
  • 4WD
  • AUTOMATIC
  • 150,000 MILES
Truck shut off while idling, upon trying to restart, it coughed and idled very roughly and shut off again. Now it does not fire at all.
Checked fuel pump pressure at rail and is 60 PSI. After discovering no spark, began checking the ignition system. First step was checking ICM voltage on the pink wire, but it has 1.5vdc, regardless of key position. Does this point directly to an ignition switch issue? Based on how it shut off and reacted, I would have thought coil. Suggestions?
Do you
have the same problem?
Yes
No
Monday, July 12th, 2021 AT 9:50 AM

1 Reply

Tiny
JACOBANDNICKOLAS
  • EXPERT
Hi,

Is there an RPM signal when cranking the engine (if there is a tachometer in the vehicle)? If there isn't, do you have access to a live data scan tool? If you do, check for an RPM signal to see if there is one. If there isn't, my first suspect is the crankshaft position sensor.

Take a look through this link. It discusses the most common symptoms of a bad crankshaft position sensor.

https://www.2carpros.com/articles/symptoms-of-a-bad-crankshaft-sensor

Also, I attached pics below showing the entire wiring schematic for the engine controls. I highlighted the wire you are referring to. It should have 12v from the injection 1 fuse. Check that fuse as well. Also, make sure not only the fuse is good, but also that it has power to and from it. (with the key on run position). Here is a link you may find helpful:

https://www.2carpros.com/articles/how-to-check-a-car-fuse

Note: I had to cut the schematics in half to make them readable. I did overlap them so you can follow from one to the next. Also, the highlighted wire is the one to the module.

Take care,

Joe
Was this
answer
helpful?
Yes
No
Monday, July 12th, 2021 AT 9:21 PM

Please login or register to post a reply.

Sponsored links