No dash, running, or turn signals

Tiny
81SCRAMBLER
  • MEMBER
  • 1981 JEEP SCRAMBLER/CJ8
  • 5.9L
  • V8
  • 4WD
  • MANUAL
  • 810 MILES
It has a painless wiring kit in it. I recently bought it off a guy the way it is. I thought it could be a simple fix like bad bulbs or a fuse or even a cut wire but turns out it is not. Tomorrow I am replacing the light switch to see if this remedies the issues. My headlights Lo/Hi work fine. Reverse and brake lights work. The dome light even works. However I have no running/parking lights, no dash lights and no turn signals. All my fuses are good. The only ones I am not sure of are the fuses for he flashers as they are round and not see through (they look okay and not burnt) the only other thing that may play a part is I have LED taillights. I have seen pictures where the lights worked so not sure what is going on. Any help or ideas will help.
Do you
have the same problem?
Yes
No
Wednesday, April 19th, 2017 AT 5:58 PM

1 Reply

Tiny
STEVE W.
  • EXPERT
I would start by taking a test light and checking the fuses. Then follow the wires from the problem areas back to the switches. For the turn signals a bad fuse or flasher could cause them to fail. With the dash/running lights it would depend on how they were wired. If you follow the power flow from the battery to the switch and out of the switch to the lights the problem should show up real quick.
Was this
answer
helpful?
Yes
No
Wednesday, April 19th, 2017 AT 6:15 PM

Please login or register to post a reply.

Recommended Guides