No click, no crank, no start, no dash lights

Tiny
CLIF MORRIS
  • MEMBER
  • 1990 TOYOTA PICKUP
  • 3.0L
  • 6 CYL
  • 2WD
  • MANUAL
  • 175,000 MILES
I do have headlights and hazard lights but also no turn signal lights. I have a brand new battery. I put the key into the ignition and nothing, not even the check engine light comes on. Appears no power to the ignition switch. How can I test the fusible link/80 amp fuse coming from the fuse box under the hood? And would this be an option if I am not getting any power to my ignition switch. I have a multi-meter but not certain what to put it on or a test light and also how to test the ignition switch from the switch itself to see if it has gone out. I am also not getting any lights on the test light for the fuse box below.
Do you
have the same problem?
Yes
No
Wednesday, March 25th, 2020 AT 12:20 PM

1 Reply

Tiny
SCGRANTURISMO
  • EXPERT
Hello,

This could be a problem with your AM2[30A] fuse located in R/B 2 Fuse Box on the right hand side of the engine compartment. Here is a link below explaining how to do this:

https://www.2carpros.com/articles/how-to-check-a-car-fuse

In the diagrams down below I have included the starting circuit wiring diagrams and the R/B 2 diagrams for your vehicle for reference. Please check this fuse and get back to us with what you find out. We can go from there if needed.

Thanks,
Alex
2CarPros
Was this
answer
helpful?
Yes
No
Wednesday, March 25th, 2020 AT 12:51 PM

Please login or register to post a reply.

Sponsored links