No air flow from vents

Tiny
KRYSTEN EVANS
  • MEMBER
  • 2006 PONTIAC GRAND PRIX
  • 6 CYL
  • 2WD
  • AUTOMATIC
  • 130,000 MILES
I have no heat or air from car vents. We replaced the fuse, resistor, blower moter and control panel and still no air flow. Any suggestions?
Do you
have the same problem?
Yes
No
Friday, August 10th, 2018 AT 3:36 AM

5 Replies

Tiny
STEVE W.
  • EXPERT
A few questions first. You have no heat/AC from any of the vents? That means nothing from the defroster, dash or floor vents? Do you hear the blower motor running at all when you select high blower speed or nothing at all? Does this have the manual or fully automatic heater controls?
Was this
answer
helpful?
Yes
No
Friday, August 10th, 2018 AT 7:05 AM
Tiny
KRYSTEN EVANS
  • MEMBER
At first there was air from the defroster and floor but only on one of the lower fan settings but now that has quit too. We do not hear the blower motor running at all. I have manual heat and air settings.
Was this
answer
helpful?
Yes
No
Friday, August 10th, 2018 AT 6:04 PM
Tiny
STEVE W.
  • EXPERT
Sorry about the wait. Computer decided it wanted a break!
First I would check fuse 30 the main battery 4. Then verify that the blower motor control unit has a good ground.
Was this
answer
helpful?
Yes
No
Monday, August 13th, 2018 AT 3:53 PM
Tiny
KRYSTEN EVANS
  • MEMBER
Fuse is good. Will check the ground wire. Thank you
Was this
answer
helpful?
Yes
No
Wednesday, August 15th, 2018 AT 5:24 AM
Tiny
STEVE W.
  • EXPERT
If the ground checks okay then the next step would be to verify that the control signal is getting to the fan module. That would take an oscilloscope to watch the signal level as the fan speed is selected.
Was this
answer
helpful?
Yes
No
Wednesday, August 15th, 2018 AT 7:08 AM

Please login or register to post a reply.

Recommended Guides