1994 Nissan Maxima 3 INJECTORS NOT PULSING

Tiny
SED326
  • MEMBER
  • 1994 NISSAN MAXIMA
  • 6 CYL
  • FWD
  • AUTOMATIC
  • 106,000 MILES
MY CAR STARTS BUT LACKS POWER ALL CYLINDERS ARE FIRING BUT MY 2, 4, 6, INJECTORS ARE NOT WORKING I LISTENEND FOR CLICKING NOISE AND ONLY HEARD IT ON MY 1, 3, 5 INJECTORS WHAT COULD MAKE ME LOSE ONLY HALF OF THEM.
Do you
have the same problem?
Yes
No
Sunday, November 22nd, 2009 AT 4:34 PM

3 Replies

Tiny
MATHIASO
  • MEMBER
Hello sed326

there may be disconnection at the splices
on 2 ,4 ,6 ( check diagram for wire colors)
.
check terminal numbers on the pcm 110 for 2, 112 for 4, 114 for 6.
sending the diagram in your email.
is there engine code you may have forgotten to mention?
if the splices are good and the conection at the pcm are also good, then the computer may be the problem
you have also the cam sensor responsable to tell the computer wich cylinder is at top dead center so it can order the injectors to pulse ,if not working, it should be a code. have it diagnose anyway, There may be engine light but the light bulb burn out.


http://www.2carpros.com/forum/automotive_pictures/46384_0900c152800764ac2_2.jpg

Was this
answer
helpful?
Yes
No
Sunday, November 22nd, 2009 AT 5:14 PM
Tiny
SED326
  • MEMBER
YOUR RITE I FORGOT TO MENTION THAT. THE CHECK ENG LIGHT IS ON, IT'S GIVEN A MESSAGE THAT JUST SAYS FUEL INJECTOR CIRCUIT AND YOU MENTIONED ABOUT THE CAM POSITION SENSOR IT ALSO CONTROLS IGN TIMING COULD IT GO BAD IN A WAY THAT EVERYTHING ELSE WORKS EXCEPT THOSE THREE INJECTORS. P.S. THANKS FOR THAT SCEMATIC ITS A LOT BETTER THAN THE ONE I HAD.
Was this
answer
helpful?
Yes
No
Monday, November 23rd, 2009 AT 7:10 PM
Tiny
MATHIASO
  • MEMBER
Check the splices and let me know what you found.
The 3 injectoirs have splices, check them.
Yes the cam sensor will be my second guess, but the other injectors are ok!
Was this
answer
helpful?
Yes
No
Tuesday, November 24th, 2009 AT 1:26 AM

Please login or register to post a reply.

Recommended Guides