1993 Nissan Maxima V6 130,000

Tiny
MAELYN717
  • MEMBER
  • 1993 NISSAN MAXIMA
I have an aftermarket stereo, headlights, and a new stronger battery. I recently starting having a problem where the dashlights and tail lights don't come on, unless I hit the brake, then the lights come on. The fuse that controls the dashlights and tail lights keeps blowing since this started. Initially, though, the dashlights would come on when I hit the brake, but now just the tail lights come on when I hit the brake. Car is otherwise not having electrical problems. Removed the stereo to double check there were no sparking wires, which there weren't, and we re-wrapped each individual wire. If a larger fuse is put in, everything works for about an hour of driving time, then the fuse blows again. My friend could probably fix the problem if we could figure out what it is.
Do you
have the same problem?
Yes
No
Wednesday, November 28th, 2007 AT 11:08 AM

1 Reply

Tiny
FISHERMAN
  • MEMBER
Hello !

Looks to me like you re pulling the positive of the stereo from the wrong wire.

Once you install an aftermarket stereo you should run a new wires directly from the battery, the wires on the car are "design" to handle certain "load" if your "new" radio pulls more amps and its connected on the wrong wire you re going to experience a problem.
Double check your radio wiring and if necessary run new wires to it.

Good Luck!
Was this
answer
helpful?
Yes
No
Wednesday, November 28th, 2007 AT 11:28 AM

Please login or register to post a reply.

Recommended Guides