NISAAN ALTIMA 1996 STOPS AFTER RUNNING FOR A WHILE

  • Tiny
  • Bpr2502
  • 1996 NISSAN ALTIMA

I have 1996 Nissan Altima. When I bought this car, it had transmission rebuilt. Car was running fine for almost 1 year.I had a small accident where the body. Passenger side fender was damaged. Nothing else was damaged as per the mechanic. After that fixed the Oxygen sensor. After that this car use to stop after driving for around 40-50 miles and after that it will have jurks and then all the lights will be on and then the car will stop. Midas suggested that the distributor is gone. So I chaged that. Then it was running fine. Again after few days this car started giving same problem. So on mechanic suggested to change the Spark plug and fuel injector. So I changed that. Still the car has problem. It will stop after few miles giving some jurks and then all the lights will be on. And car won't start. But after 3-4 hours this car starts again. But then again after running for few miles it will stop. Till now nobody is able to find what's the problem. Now Midas has asked me to change the belts and also the Axle shaft which is really in bad condition. Could you please suggest what could be the problem with this car?

Do you
have the same problem?
Yes
No
Monday, January 16th, 2006 AT 5:08 PM

1 Reply

  • Tiny
  • D_arnold
  • MEMBER

Try the fuel pump, this often happens with cars if it quits while driving then starts up an hour or so later.

Was this
answer
helpful?
Yes
No
Friday, July 21st, 2006 AT 6:35 PM

Please login or register to post a reply.

Other Engine Stall Questions