NEED YOUR HELP.

Nissan Altima

Tiny

souljahslim305

May, 30, 2007 AT 8:58 PM

I have a 2003 nissan altima with a 2.5s engine automatic trans. With 94,000 miles. When I turn my engine on in the morning it does it fine, when I put my car in drive it jumps on me as if though it wants to turn off on me. When im driving down the road from time to time if feels like my car wants to turn off on me and it does sometimes but only when im coming to a stop. I changed my upstream oxygen sensor but not my downstream sensor I did a scan on it n it shows that my downstream is running lean, can this be the cause of my problem or can I be having another one, I had a trouble code p0420. I believe the the problem is with the oxygen sensor. By me letting the car run in this way can I damage the cat. Converter. Thank u 4 ur help.

FOUND 3464 RELATED QUESTIONS

3 Answers

Tiny

Jack42

May, 31, 2007 AT 8:06 AM

Has it ever been tuned up? 0420 is usually a cat efficiency code, the converter may be bad if the sensor has already been changed (downstream)

Tiny

souljahslim305

May, 31, 2007 AT 5:15 PM

I have only changed the spark plugs, done oil changes every 3 thousand miles, changed the trans. Fluid. And changed the upstream oxygen sensor. Do u think that its time for me to do a valve adjustment.

Tiny

Jack42

May, 31, 2007 AT 5:42 PM

Try cleaning the throttle bore with carb spray and a rag. Might also want to try a downstream o2 sensor

Please login or register to post a reply.

Oxygen Sensor Replacement Honda Civic 1996-20
Oxygen Sensor Replacement Dodge Stratus
Fail Your Smog Test? Fix it Fast
Code Read Retrieval/Clear
Code Read Retrieval/Clear Scion XD
Code Read Retrieval/Clear Mercedes-Benz C230