2001 Nissan Altima intermittant cuugging at idle

Tiny
ERUSCH
  • MEMBER
  • 2001 NISSAN ALTIMA
  • 4 CYL
  • FWD
  • AUTOMATIC
  • 14,100 MILES
When stopped with engine at idle the engine rpm goes down to the point you think the engine will stall out, it has good pickup when you start out, at 50mi. It seems good but when you take your foot off the gas you can see the tach surge about 4000 rpm a few times then settle down, I've changed the plugs, wires, cap and rotor nothing seems to help, I'm thinking something electronic, got any suggestions were to start?
Do you
have the same problem?
Yes
No
Tuesday, August 18th, 2009 AT 10:16 AM

9 Replies

Tiny
STEVEW84
  • MEMBER
Check engine light on or are there any codes?
Was this
answer
helpful?
Yes
No
Tuesday, August 18th, 2009 AT 12:42 PM
Tiny
ERUSCH
  • MEMBER
The check engine light has came on but doesn't say on, took to Autozone and they come up with a code 4 which they say it has something to do with cyclinder 4, thanks for you help.
Was this
answer
helpful?
Yes
No
Tuesday, August 18th, 2009 AT 3:22 PM
Tiny
STEVEW84
  • MEMBER
Is it a p0304? If so, then you have a cyl 4 misfire.
Was this
answer
helpful?
Yes
No
Tuesday, August 18th, 2009 AT 5:03 PM
Tiny
ERUSCH
  • MEMBER
Yes that's correct p0304 and the guy said it was a misfire in cyl 4, what is the next step?
Was this
answer
helpful?
Yes
No
Wednesday, August 19th, 2009 AT 5:32 AM
Tiny
STEVEW84
  • MEMBER
Now you have to see why it is misfiring. Since you said you already did plugs, wires, cap and rotor then you have something else. Either bad fuel inj, bad compression on that one cyl, or possible you have some air leakage from a bad intake gasket. This is where it gets hard, because you need a scanner, a noid light, inj. Tester, and compression gauge to see why it is misfiring.
Was this
answer
helpful?
Yes
No
Wednesday, August 19th, 2009 AT 10:06 PM
Tiny
ERUSCH
  • MEMBER
Looks like I'll have to take it to dealer or find a good mechanic in my area because I don't have access to any test equipment like that, the one thing that confuses me is that if it had low conpression or a bad gasket I would think the problem would be constant and not intremittant because the car seems to run good until it goes to idle such as stopping at a traffic light when you first stop the motor runs ok then within 10 sec. Or so it'll start to chugg then after a few more sec. It'll run good again and so on until you step on the gas pedal at which time it runs good.
Was this
answer
helpful?
Yes
No
Thursday, August 20th, 2009 AT 10:22 AM
Tiny
STEVEW84
  • MEMBER
If it is intermittent then it is definently not a compression issue. If you notice it more at idle then I would almost think it would be a bad intake gasket. Honestly, I'm just guessing though.
Was this
answer
helpful?
Yes
No
Thursday, August 20th, 2009 AT 11:55 AM
Tiny
ERUSCH
  • MEMBER
OK thanks for you advice I'll check it it out and get back with what I find.
Was this
answer
helpful?
Yes
No
Thursday, August 20th, 2009 AT 1:11 PM
Tiny
ERUSCH
  • MEMBER
This message is for stevew84. Took the car to Nissan and they said the same as you a bad intake gasket so I had them change it and the car runs great. Thank you.
Was this
answer
helpful?
Yes
No
Monday, October 19th, 2009 AT 1:47 PM

Please login or register to post a reply.

Recommended Guides