1997 Nissan Altima Stuck in 2nd Gear

Tiny
ADLPN
  • MEMBER
  • 1997 NISSAN ALTIMA
  • 4 CYL
  • FWD
  • AUTOMATIC
  • 300,000 MILES
Automatic transmission/ Car barely goes when taking off and does not shift after getting up to about 55mph. Check engine light came on and problem started after fixing stoplight switch and attempting to fix cruise control switch (do not know if it is related)
Do you
have the same problem?
Yes
No
Monday, June 21st, 2010 AT 8:49 PM

7 Replies

Tiny
KHLOW2008
  • EXPERT
Hi adlpn,

Thank you for the donation.

Symptoms indicates the transmission is locked in 3rd gear and would not up or down shift.

Get a free scan done at Autozone and let me know the exact trouble codes so we can proceed from there.
Was this
answer
helpful?
Yes
No
Tuesday, June 22nd, 2010 AT 1:28 PM
Tiny
ADLPN
  • MEMBER
Code P1605 A/T communications line
Was this
answer
helpful?
Yes
No
+1
Wednesday, June 23rd, 2010 AT 11:43 AM
Tiny
ADLPN
  • MEMBER
Also have 1 more? Under the center console beside the gear selector there is a little box with a spring at one end then a plastic piece (guessing something to do with neutral safety) with a metal piece attached that goes into the dash area as a cable. It use to click and now does not what is this and could it be the problem/
Was this
answer
helpful?
Yes
No
Wednesday, June 23rd, 2010 AT 12:37 PM
Tiny
KHLOW2008
  • EXPERT
I have emailed the diagnostic procedures for P1605. Let me know if you do not receive it shortly.

The cable is for the key interlock and does not affect the trouble code. If it does not operate, you would not be able to turn the key to the LOCK position when the gear lever is in PARK position. Alternatively you would be able to turn the KEY to LOCK position without moving the shift lever to the PARK position if it is stuck in release position.

The clicking is not from this, it should be from the gear interlock system. The solenoid would only click when brake pedal is depressed with gear position in PARK.
Was this
answer
helpful?
Yes
No
Wednesday, June 23rd, 2010 AT 1:29 PM
Tiny
ADLPN
  • MEMBER
Thank You for the help! Turns out we were both assuming the other had checked the fuse which turned out to be the problem.
Was this
answer
helpful?
Yes
No
+1
Tuesday, August 3rd, 2010 AT 7:49 PM
Tiny
KHLOW2008
  • EXPERT
Thank you for the input and glad to know you have fixed the problem.

Thank you for using 2carpros and have a nice day.
Was this
answer
helpful?
Yes
No
Wednesday, August 4th, 2010 AT 6:57 AM
Tiny
KCKYLEKC
  • MEMBER
I literally have the same problem. I fixed the stop switch as well as tried working on the cruise control cut off switch. Would you mind telling me what fuse you replaced to fix the problem?
Was this
answer
helpful?
Yes
No
+1
Saturday, August 15th, 2015 AT 12:22 PM

Please login or register to post a reply.

Recommended Guides