1997 Nissan Altima Possible sensor problem?

Tiny
SJONCAS
  • MEMBER
  • 1997 NISSAN ALTIMA
Engine Mechanical problem
1997 Nissan Altima 4 cyl Front Wheel Drive Manual 145k miles

Hi!

My little buddy of a car has developed some new problems. I recently moved to the city and drive it less frequently (2x/week) than I did in the country (which I miss!).

It started 2 months ago when I noticed that a fan remained running for apprx. 10 minutes after the car was shut off. This is strange since I have owned the vehicle for 5 years now and have never had this happen. More recently my car has further acted up to the point where after it has warmed up I cannot increase above 2000 rpms. I then pull over and restart the car and it is fine for the remainder of my trip. Additionally the heat in my car does not remain hot once the car has warmed up, it is intermittently warm.

Any help or suggestions is HUGELY appreciated. Also recommendations for mechanics in the Boston area who are reputable and reasonable is appreciated!

Thank you!
-SJ
Do you
have the same problem?
Yes
No
Monday, January 25th, 2010 AT 7:31 PM

1 Reply

Tiny
JACOBANDNICKOLAS
  • EXPERT
First, I'm sorry, but I don't know anyone in that area.

As far as the other problems, the fan could be a bad relay. Has the engine been running hot?

As far as the heater, make sure the coolant level is full and with the engine running, hot, and the heater on, check to see if both heater core hoses (at firewall) are hot.

As far as the engine, when you pull over, take a look at the catylatic converter to see if it is glowing red hot. Also, let me know if the check engine light has come on.

Let me know what you find, and thanks for using 2carpros. Com.

Joe
Was this
answer
helpful?
Yes
No
Monday, January 25th, 2010 AT 9:52 PM

Please login or register to post a reply.

Sponsored links