SMOKE UNDER HOOD...

Mitsubishi

Tiny

bird

February, 18, 2006 AT 4:15 PM

After about 20min of driving and putting the car into park... i can smell something like rubber burning smell coming under the hood... a few times ive seen white smoke coming under the Valve Cover..... i noticed this was happening about 4 months ago.... just 2 days ago there was alot of smoke coming out.. even when hood was closed... i havent seen it since... i noticed this was happening ever since i got my valve cover, timing belt and water pump changed.... that was about 4 months ago....

heres a pic hope it helps a little...

http://ca.geocities.com/p_b@rogers.com/4-1.jpg

my car is a 99 mitsubishi eclipse n/t

FOUND 40 RELATED QUESTIONS

13 Answers

Tiny

nightroad

February, 19, 2006 AT 3:53 PM

From the picture it looks like the seal job was done in poor effort. Best way is to take off the valve and see if anything like the seal started melting or falling in the engine. Did it get the gasket installation when parts were being replaced? Was the right seal adhesive been used(having a resist of high temperature)? Thats all I can give. Ask a local shop for more tips

Tiny

lamby22

February, 28, 2006 AT 3:49 PM

I to have been having this problem.I bought my car from carmax and about a week later after about 30 min driving from my work I notice a burning rubber smell when I get out.I look under hood and I see white smoke coming from underneath the engine.I have no idea what this could be.I replaced my head gasket a couple of weeks ago but the white smoke still comes when I park. The engine does not overheat but it bothers the hell outta me. Plz help

Tiny

bird

March, 6, 2006 AT 11:14 AM

Which car do you own?

Tiny

lamby22

March, 6, 2006 AT 1:54 PM

99 black eclipse

Tiny

Antoniotgsx

March, 6, 2006 AT 9:20 PM

Check to make shure the right sealant was used. Repace intake and exhaust gaskets.

Tiny

lamby22

March, 7, 2006 AT 3:42 PM

I have cold air intake. That wouldn't have caused the smoke I dont think

Tiny

bird

March, 7, 2006 AT 11:41 PM

I hope not I have an aem short ram instake.

Tiny

lamby22

March, 8, 2006 AT 9:17 AM

I talked to carmax today and they said its the main head gasket and the valve cover gasket. Thats whats causing it

Tiny

bird

March, 8, 2006 AT 10:11 AM

If the main head gasket isnt changed can it cause problems with other parts in the future?

Tiny

lamby22

March, 8, 2006 AT 10:54 AM

Yea. It can cuase water in the oil and the part cost 250 plus labor. Really sucks

Please login or register to post a reply.

Hood Shock Replacement - Rear Porsche
Open Hood Video
Wiper Blade Replacement Toyota Tacoma
Window Switch Replacement and Test
Trunk Shock Replacement Porsche Carrera 911