99' Mitsubishi Galant will not turn over

Tiny
DIXIECHICK91
  • MEMBER
  • 1999 MITSUBISHI
I purchased a 99' Mitsubishi Galant for my daughter last year had work done it ran perfect. My son went into the hospital and was there for about 6 months and the car sat undriven. Well now she has time to drive and the car would not start. I bought a new battery and the car will not turn over. Check the ignition fuse. Looked OK, but replaced it any way. Did not help. The lights come on the dash (looked for a security light/alarm on the dash. Thinking of some fail safe trigger. But no). Can not locate a fuse box/panel under the hood only the one on the inside drivers door. Does anyone have a suggestion?
Do you
have the same problem?
Yes
No
Saturday, April 21st, 2007 AT 9:28 PM

4 Replies

Tiny
DIXIECHICK91
  • MEMBER
Well, I have recleaned the battery cables, found the fuse box under the hood and all look good. I even tried to bang on the starter (which now I know was not the starter. The starter is under the exhaust and behind a fire plate) and tried to jump it off. The car will not turn over and the battery is now low. I took the battery back to Auto Zone and had them check it. The battery is fine. So now I am thinking it is the starter. Any suggestions? :Idea:
Was this
answer
helpful?
Yes
No
Sunday, April 22nd, 2007 AT 5:15 PM
Tiny
ANDY MCLAUGHLIN
  • MEMBER
Hi Dixiechick 91,
I can sympathise.
I have a 97 Mitsubishi Montero- sounds like it has the exact same issue that you have- it sat for about 2 weeks (last Nov) without use and then I went to start it but just no power to the starter -(battery was good) I suspect the a neutral safety switch (read the question I submitted on 4/22/07 "Mitsubishi Electrical problem- no replies so far)- Please please please contact me if you find a solution to fix your electrical problem as I think my problem is exactly the same as yours- my e-mail is:
mclaughlinandy@yahoo. Com- send me your e-mail and if I manage to find a solution I will notify you of how to fix it as well. Please keep in touch if you solve your problem.
Andy
Was this
answer
helpful?
Yes
No
Monday, April 23rd, 2007 AT 10:24 PM
Tiny
DIXIECHICK91
  • MEMBER
I am soooo sory to hear that. I sure hope that is not the case for me. Will let you know if I can get it started.

Thanks
Was this
answer
helpful?
Yes
No
Tuesday, April 24th, 2007 AT 6:27 PM
Tiny
SHOGUN418
  • MEMBER
I got the same problem I even switched out computers and the distributor but still nothing. Im thinking maybe a bad line some place.
Was this
answer
helpful?
Yes
No
Monday, April 30th, 2007 AT 7:20 AM

Please login or register to post a reply.

Recommended Guides