2001 Mitsubishi Montero O2 Sensor

Tiny
SHOOPDAWG
  • MEMBER
  • 2001 MITSUBISHI MONTERO
  • 6 CYL
  • 4WD
  • AUTOMATIC
  • 105,000 MILES
The engine light in my Montero came on. Since it just hit 100,000 miles, I decided to have a 27 point inspection and some other things done, as well as have the engine light checked out at my local Mitsubishi dealer.
They told me I had a bad O2 Sensor and they did the 27 Point inspection which included an oil change. We picked up the car. When on the highway going about 60 miles an hour after about 60 miles of driving, the engine light came back on. We took it back, they told us the code revealed was one they never saw before. They cleared the code and gave it back to us. Less than 100 miles later, the engine light came back on. We took it back. This time they are telling me the O2 Sensor is bad again, but it was caused by an oil leak and the oil was running down the harness into the O2 Sensor causing it to go bad. My question is: Is this BS? Can an oil leak cause an O2 Sensor in a 2001 Mitsubishi Montero to go bad?
Do you
have the same problem?
Yes
No
Wednesday, October 8th, 2008 AT 12:50 PM

1 Reply

Tiny
IMPALASS
  • EXPERT
Hello, first I show several different Montero 4WD models. I am going with Sport ES. The truck has 4 Oxygen sensors on it. I have attached the pics. You really need to know what the codes are. There are a couple of technical service bulletins out, but again, need to know the correct model of the vehicle and what the codes were. Stop by Auto Zone or O'Reilly's. For free they can pull the codes and if it is an O2 sensor, it will tell you what position. I would be more concerned with what sensor they changed and what code they saw. As for the oil......well, there is a slim possibility. It does raise the question that if it were that new it should be more durable..........it does kind of make you say, mmmmmm...........These are heated and any fluid that would interrupt the connection may cause a problem. It is possible you had two sensors go bad. Let's check the codes first. Where is the oil coming from would be my next concern especially if it was running down the cable. Let us know


http://www.2carpros.com/forum/automotive_pictures/248015_Oxy_1_1.gif



http://www.2carpros.com/forum/automotive_pictures/248015_Oxy_2_1.gif



http://www.2carpros.com/forum/automotive_pictures/248015_Oxy_3_1.gif



http://www.2carpros.com/forum/automotive_pictures/248015_Oxy_4_1.gif

Was this
answer
helpful?
Yes
No
-1
Wednesday, October 8th, 2008 AT 10:25 PM

Please login or register to post a reply.

Recommended Guides