1997 Mitsubishi Galant Transmission slipping/no overdrive

Tiny
MOM2MALACHI
  • MEMBER
  • 1997 MITSUBISHI GALANT
  • 4 CYL
  • 2WD
  • AUTOMATIC
  • 135,000 MILES
I purchased this car January 28, 2008 & after leaving the dealership it started "revving" out between 1st & 2nd gear and then an extremely hard shift. We then discovered it also had no overdrive. A couple of days later the check engine light came on & was diagnosed as cylinder 2 misfire & faulty speed sensor. We replaced all plugs, wires, etc & the speed sensor. Check engine light was reset & did not come back on. However the "revving" did not stop, nor did the hard shift & still no overdrive. The dealership got a used transmission for us & my husband installed it & the problem is no different except there is no "slamming" into gear (no hard shift). I find it unlikely we'd have the same problem w/ 2 different transmissions, however nobody seems to be able to offer any ideas... Can you help? Thank you, Jessica M. Bourn
Do you
have the same problem?
Yes
No
Wednesday, March 19th, 2008 AT 10:45 AM

1 Reply

Tiny
MARCUS15
  • MEMBER
I have a 1997 Galant also. Before I bought it I asked a dealer about the model and he mentioned that it was known for transmission problems. I bought it anyways had it for about 3 years now. The hard shifting (OD on) was a regular occurence. Just recently the same problem you mentioned started, the slipping between gears and check engine light is on. I turned off the OD and actually it seems to be running normal (except for the lack of overdrive of course) I'm not a mechanic and can't offer any solution. Just thought I 'd let you know that this seems to be an issue with this car, since I have the EXACT same problem.
Was this
answer
helpful?
Yes
No
-1
Tuesday, April 15th, 2008 AT 3:48 PM

Please login or register to post a reply.

Recommended Guides