Metal flakes at VVT exhaust solenoid screen and loud tapping noise

Tiny
LEERAIMO
  • MEMBER
  • 2012 KIA FORTE
  • 2.4L
  • 4 CYL
  • 2WD
  • AUTOMATIC
  • 117,000 MILES
My vehicle was making loud tapping, with engine light on.
Checked oil, barely touching stick. Added 1.5 quarts. Was about 6,500 miles over on change. Never had this issue before? Topped off.
Pulled codes P0011 and P0014. VVT intake/exhaust solenoid, Removed/cleaned/tested/replaced. Notice metal flakes/circular on exhaust screen.
Vehicle seems to be functioning better. Have changed oil test drive. Still loud tapping at takeoff/hard acceleration over third gear. Removed exhaust solenoid again and found move metal flakes on screen. Concerned
Do you
have the same problem?
Yes
No
Tuesday, May 21st, 2019 AT 11:15 AM

1 Reply

Tiny
KASEKENNY1
  • EXPERT
Hi Leeraimo,

I understand the concern and I would share it. The metal you are finding is most likely from a bearing. The tapping is most likely the source of the metal so it is either the cam or crank that is causing it.

It is common when you find metal in the solenoid screen that it is throughout the engine. More than likely when the engine ran low on oil, it actually pulled air into the oil pick up and not oil and this allowed the bearings to run with no oil for a enough time that they are scored. Once this happens, it unfortunately only gets worse.

I would suggest draining the oil through a coffee filter so that you can see how much metal is in the oil. However, if the tapping is not changing after new oil, most likely you will need to pull the oil pan and valve cover to look at the bearings.

Please let me know if you need anything else.
Was this
answer
helpful?
Yes
No
Tuesday, May 21st, 2019 AT 4:01 PM

Please login or register to post a reply.

Recommended Guides