1999 MERCURY SABLE CRUISE AND HORN SUDDENLY INOPERATIVE

  • Tiny
  • Gas2001tech
  • 1999 MERCURY SABLE

Electrical problem
1999 Mercury Sable 6 cyl Two Wheel Drive Automatic 200000 miles

The cruise control on this 1999 Sable has suddenly stopped working. After some troubleshooting, I think I have ruled out the fuses and brake switch. During the process, I found the horn does not work. Am I looking at a steering column pull job?

Thanks

Do you
have the same problem?
Yes
No
Saturday, July 31st, 2010 AT 1:28 PM

3 Replies

  • Tiny
  • Merlin2021
  • EXPERT
  • 17,584 POSTS

You are most likely looking at the clockspring, you do need to remove the steering wheel.

Was this
answer
helpful?
Yes
No
Saturday, July 31st, 2010 AT 1:32 PM
  • Tiny
  • Gas2001tech
  • MEMBER

Initially, I checked the fuses under the dash, all were fine. Since there was no common fuse for the Cruise Control and the Horn, I assumed the 2 weren't related, except thru marriage at the steering wheel. After more investigation, I checked the fuse block under the hood, found a blown fuse for the horn (no reference to the Cruise in the owner's manual), replaced it, and the horn and the Cruise now work.

Hope this may save others some looking. Merlin, thanks for the reply. I will save the clockspring question for later, should I need it. Hoping not to.

Thanks again.

Was this
answer
helpful?
Yes
No
Monday, August 2nd, 2010 AT 7:14 AM
  • Tiny
  • Merlin2021
  • EXPERT
  • 17,584 POSTS

OK, I'll be watching out, if it blows again, we will check the steering wheel switches, and the clockspring out.

Was this
answer
helpful?
Yes
No
Monday, August 2nd, 2010 AT 1:11 PM

Please login or register to post a reply.

Other Horn Not Working Questions