1994 Mercedes Benz C280 Rough Idle

Tiny
CHEMICAL_DREAMS
  • 1994 MERCEDES BENZ C280

Engine Performance problem
1994 Mercedes Benz C280 6 cyl Two Wheel Drive Automatic 159000 miles

When my car first starts it seems fine until it begins to heat up. Once it is warmer, about 60ºC and I am at a stop the engine will drop RPM's a little bit but will shark and the lights on my instrument cluster will dim a bit, like the car is trying to die. I have had the spark plugs, wires and ignition coils replaced recently and just had the oxygen sensor replaced as there were giving off codes for the never ending check engine light. After the O2 sensor was replaced this got much worse, to a point where it is almost constantly doing this shaking and much more violently. I suspect it is either the IAC or MAF sensor but am not sure. A friend also told me it may be as simple as a bad connection in the ignition system somewhere. Any assistance would be deeply appreciated!

Do you
have the same problem?
Yes
No
Monday, March 31st, 2008 AT 2:38 PM

1 Reply

Tiny
WILSEMAIL
  • MEMBER

MAF sensor is a good guess. Try cleaning it with spray cleaner first, but does the exhaust look black? If so, rich mixture. I would check the fuel pressure. Fuel filter first, then check the air boot line going from air filter to intake. Then I would think about the fuel pressure regulator. This is either in the fuel rail or part of the fuel filter, I don't remember on that one.

Was this
answer
helpful?
Yes
No
Saturday, April 12th, 2008 AT 1:13 AM

Please login or register to post a reply.

Other Engine Idle Rough Questions