Low revs and now stalls at idle

Tiny
PREGGYN
  • MEMBER
  • 2007 TOYOTA
  • 3.0L
  • TURBO
  • 2WD
  • MANUAL
  • 400,000 MILES
I had low revs and decided to change the diesel filter. Unfortunately I did not change the "O ring" for the housing and threw that away. Now it is switching off more often. Almost every time I am at a stop or robot. I tried pressing the top of the diesel filter plunger and seems that it helps for a short while. When it switches off it used to start immediately but now sometimes takes some effort to start.

Previously it used to go into limp mode or protection if I drive over 140 km/h. Stop it stalls and start again and it is good to go until I exceed 140 km/h again.

Please help.
Do you
have the same problem?
Yes
No
Tuesday, September 27th, 2016 AT 11:55 PM

6 Replies

Tiny
KEN
  • ADMIN
Hello, it sounds like you have one of two things happening, first I would replace the o ring seal at the fuel filter, next it could be the main injector pump going out which is common for those cars with that mileage.

Please let us know what you find so it will help others.

Best, Ken
Was this
answer
helpful?
Yes
No
Saturday, October 1st, 2016 AT 10:41 AM
Tiny
PREGGYN
  • MEMBER
Hi Ken. Thank you for the reply. The O ring was replaced and I also removed the filter to observe and exactly the same problem. If I keep it at a slightly higher rev then there is no problem. I did diagnostics and it did not pick up anything even though it switched off during the test as well.

For now I am driving it like that.

Regards,
Preggy
Was this
answer
helpful?
Yes
No
Sunday, October 2nd, 2016 AT 12:07 AM
Tiny
KEN
  • ADMIN
Hi Peggy,

You may want to have the injector pump checked, it sounds like it might be weak. The compression could be down as well.

Best, Ken
Was this
answer
helpful?
Yes
No
Monday, October 3rd, 2016 AT 8:53 AM
Tiny
PREGGYN
  • MEMBER
Hi Ken. Thanks I would have to get that checked tomorrow as it switches off more often now and I have a long trip this weekend so have to do it ASAP. I again replaced the diesel filter today which is just less than 1000km ago and the filter was quite dirty. Sometimes the idle sounds a bit funny or rowdy should I say. Will let you know how it goes.
Preggy
Was this
answer
helpful?
Yes
No
Monday, October 3rd, 2016 AT 10:01 AM
Tiny
PREGGYN
  • MEMBER
Hi Ken, Thank you for all the suggestions and help. I took the Hilux in to a diesel specialists and they found the "Suction Control Valve" to be faulty. This can not be picked up on the electronic diagnostics but was a trail and error but at least it was the first thing that they looked at

That problem is now gone and does not switch off anymore by itself but I tested it and it still goes into limp mode above 140km/h.

Regards,
Preggy
Was this
answer
helpful?
Yes
No
Monday, October 10th, 2016 AT 2:21 PM
Tiny
KEN
  • ADMIN
Glad we could get it fixed please use 2CarPros. Com anytime we are here to help

Best, Ken
Was this
answer
helpful?
Yes
No
+1
Monday, October 10th, 2016 AT 2:27 PM

Please login or register to post a reply.

Recommended Guides