1995 Lexus ES 300 High RPM / fast idle when cold

Tiny
MATEJ87
  • MEMBER
  • 1995 LEXUS ES 300
  • 6 CYL
  • FWD
  • AUTOMATIC
  • 142,000 MILES
IAC or MAF? That is the question :-) The check engine light was on (IAC malfunction), until complete intake cleanup. Now IAC is fine. But somehow the problem with RPM still occurs. TPS, engine temp sensor and oil sensor was measured, resistances were OK. When the engine is warming up, rpm decreases till cca 700, when warmed-up and I can stop and start engine again with normal rpm. Until next morning. Cold start at 1800rpm (does not matter if outside temperature is -20Celsia or +20Celsia). After cca 30 seconds drop to 1500 and slowly decreasing. This is first issue that happened to our Lexus althought it is 14 yrs old. Thank you carpros. Sedlakmatej@masab. Sk
Do you
have the same problem?
Yes
No
Thursday, April 16th, 2009 AT 9:55 AM

3 Replies

Tiny
BLACKOP555
  • EXPERT
Has the idle always been high? Jsut come up all of a sudden with the IAC module?

How high did it used to idle? When the idle goes down is it at the proper level?

With vehicle shut off and turned back on with engine warm will the idle go down?
Was this
answer
helpful?
Yes
No
Sunday, April 19th, 2009 AT 8:49 AM
Tiny
MATEJ87
  • MEMBER
Sorry for late reply.
OK so, every morning when I start the engine, it revs up to 1800rpm. It stays there for 2 minutes, after that temperature gauge raises a littlebit, then rpm will decrease to 1500rpm. After another 1 minute, it jumps to 1200 and slowly to 700 - that is when the engine is warmed up. Yes, it was always like that. I have searched a few forums, where people claimed that it is somehow ok for those cars. Till this petrol Lexus, I always had diesel cars, which always started at approx. 800rpm. Oil change by Lexus is 12000km, so maybe it is ok. Afterall this car runs like a charm. So thank you for your reply.
Was this
answer
helpful?
Yes
No
Sunday, May 10th, 2009 AT 6:24 PM
Tiny
MATEJ87
  • MEMBER
I think this might be the issue. Photo while engine was fully warmed up and idle. Throttle stop screw and stop lever on TB has no clearance. But throttle opener has. Should I unscrew throttle stop screw until this 5mm opener clearance disappear?


http://www.2carpros.com/forum/automotive_pictures/344832_moto_0195a_1.jpg

Was this
answer
helpful?
Yes
No
-1
Sunday, May 24th, 2009 AT 3:34 PM

Please login or register to post a reply.

Recommended Guides