2000 Lexus ES 300 Idles High

Tiny
LEXUSPADDY
  • MEMBER
  • 2000 LEXUS ES 300
  • 6 CYL
  • 2WD
  • AUTOMATIC
  • 99,000 MILES
Ok, my lexus idles high. After I start it, and it warms up it idles aaround 1200 in park and 1000 in drive. It will slowly start to drive by itself, if if dont even push the gas. ALSO when I am driving, and coming to a stop, the rpms jump when im braking. I cant figure this one out. I have cleaned the IAC valve, right throttle body, and replaced the O-2 sensor. I can tell a little change but its still not right. I read that I should clean the Mass airflow sensor to. Can someone please help. This is killing me!
Thanks!
Do you
have the same problem?
Yes
No
Friday, March 12th, 2010 AT 8:07 AM

8 Replies

Tiny
LEGITIMATE007
  • EXPERT
Yeah cleaning the airflow sensor, maybe a good idea. But dont forget the mapp sensor, this measures load and change in elevation, and will retard the timing and injector pulse accordingly, if faulty, it will give false readings to the computer, causing the high idle, you may also want to check for vacuum leaks, get a can of brake kleen and mist it around the hoses and intake manifold. If the idle changes, that is where your leak is. Keep me posted
Was this
answer
helpful?
Yes
No
Friday, March 12th, 2010 AT 8:14 AM
Tiny
LEXUSPADDY
  • MEMBER
Hey thanks for you help! This maybe a stupid question, but where is the mapp sensor located? Is it near the mass airflow sensor? And what should I use? I heard q-tips and rubbiing alcohol.
Was this
answer
helpful?
Yes
No
Friday, March 12th, 2010 AT 9:02 AM
Tiny
LEGITIMATE007
  • EXPERT
Ok, this vehicle doesnt have a mapp sensor, just a MAF sensor, and there is special spray at the parts store for cleaning it, do not touch it until reading the instructions, they are very sensitive and can easily be damaged, also make sure the air filter it clean/new
Was this
answer
helpful?
Yes
No
Friday, March 12th, 2010 AT 9:11 AM
Tiny
LEXUSPADDY
  • MEMBER
Alright great. I will be working on it in a little bit and will let you know. I dont think there is a vac. Leak but will try that also. Do you think there is anything else I should try? To fix the idle prob? What about the egr valve? Where is that located on my model?

I really appreciate your help!
Was this
answer
helpful?
Yes
No
Friday, March 12th, 2010 AT 9:24 AM
Tiny
LEGITIMATE007
  • EXPERT
No, not at this point, but I still think you may have a problem with the iac, (idle air control valve). I know you cleaned it, but it should be tested, too, I dont wanna just tell you to replace it, that may be wasting money, and the test procedure is not too convincing
Was this
answer
helpful?
Yes
No
Friday, March 12th, 2010 AT 9:29 AM
Tiny
LEXUSPADDY
  • MEMBER
Ok. Cleand the air flow sensor, and put a new filter in, the old filter was DIRTY and had leaves and dirt in the base of the compartment. I noticed the compart ment base was loose, and that the bolts holding it in had black rubber seals. Is the base suppose to be air tight?
The car drives better and sounds better, but im still haveing idle problems. Whats your next suggestion?
Was this
answer
helpful?
Yes
No
Friday, March 12th, 2010 AT 1:35 PM
Tiny
LEGITIMATE007
  • EXPERT
Should be airtight, because you wil also loose some vacuum too, the vacuum that is pulling the air throught the filter. That high ilde maybe from the vacuum leaks. Look for more leaks, fuel filter and pop some injector cleaner in the tank if you cannot actuallly check the injectors.
Was this
answer
helpful?
Yes
No
Saturday, March 13th, 2010 AT 8:17 AM
Tiny
JSCRISTOFER9
  • MEMBER
Do you fix your problem with the high idle?
And how you fixed, because I have the same problem,
thank you
Was this
answer
helpful?
Yes
No
-1
Thursday, December 25th, 2014 AT 5:26 PM

Please login or register to post a reply.

Recommended Guides