1998 Jeep Cherokee starting problems

Tiny
MARSHALLSAMPED
  • MEMBER
  • 1998 JEEP CHEROKEE
  • 6 CYL
  • 4WD
  • AUTOMATIC
  • 170,000 MILES
I have a 98 jeep grand cherokee. It starts when it feels like it. When it does start, it clicks like crazy and sounds like the starter motor isnt engaging correctly, but it will start. Someimes it will only click a couple of quick times and just stop, nothing will happen. Like if you try and start it in drive. When its driven for a bit afterwards, like a couple of miles, it will start fine. Like nothing is wrong, no matter how many times I try and start it. If it sits for too long, it wont start right again. And when it sits overnight, sometimes it wont start at all. Also sometimes it only starts in neutral, but still with all the loud noise. New starter, battery, ignition coil, starter relay, wires all look fine, dont think its the neutral safety switch but not sure. Please help. Would like to fix myself. Thanks
Do you
have the same problem?
Yes
No
Wednesday, May 13th, 2009 AT 3:54 PM

3 Replies

Tiny
JDL
  • EXPERT
Hello, I saw what you replaced, doesn't matter, you need to check the circuits at the starter relay. You need to do the testing when the starter refuses to crank. Most relays have a wiring diagram on them so you should be able to tell the switch side of relay and the coil side of relay. Voltage to the switch side of relay is hot all the time. The voltage to the coil side of relay, goes hot with the key in the crank position. Use a testlite.

You might be able to tell if there is a load on the starter circuit. You need to test when it refuses to crank. Turn on the headlites, with the key in the crank position, what is the reaction form the lites? Stay bright-- go out, what?
Was this
answer
helpful?
Yes
No
Wednesday, May 13th, 2009 AT 4:16 PM
Tiny
MARSHALLSAMPED
  • MEMBER
Hi, I tested at the relay and I have power. I also have power when I trurn the key in the other side and so on. I tested for power at the starter and I have it, but I dont have power there when I turn the key(probe switched). So I guess its in the wiring or a connection or something? I took all the plastic shielding off of the harness and all the wiring and connections look good. Im still stumped. Thanks.
Was this
answer
helpful?
Yes
No
Thursday, May 14th, 2009 AT 4:17 PM
Tiny
MARSHALLSAMPED
  • MEMBER
I forgot to ask. What would be the reasoning for it starting completly fine when its been driven for a bit? Only when the engine is hot it would start right. And now it hasnt started in 3 days. It was an intermittent thing. Now it just wont start. Electrical issues suck.
Was this
answer
helpful?
Yes
No
Thursday, May 14th, 2009 AT 4:21 PM

Please login or register to post a reply.

Recommended Guides