1996 Jeep Cherokee cuts out unexpectedly

Tiny
ANGIEMOORE
  • MEMBER
  • 1996 JEEP CHEROKEE
  • 6 CYL
  • AWD
  • AUTOMATIC
  • 100,000 MILES
My jeep has developed a problem cutting out! It runs fine for 1/2 hour to an hour then it will just die? Sometimes she starts straight back up and runs just for a few seconds and sometimes she wont start at all?
could this be the crank position sensor?
please help
Do you
have the same problem?
Yes
No
Thursday, December 18th, 2008 AT 1:22 PM

3 Replies

Tiny
ANIMALFARM
  • MEMBER
An intermittent CPS problem can be a booger to diagnose, but I'll copy/paste my reply to a previous CPS problem to save time re-typing. Definitely recommend following the procedure to get the "Codes", might help lead you in the right direction.

Just had a very similar problem in my 1996 cherokee with 4.0 inline 6 - turned out to be the crankshaft position sensor. Jeep would crank but not start, no spark, no pressure in the fuel rail, only lights that would come on in the dash were the brake and seatbelt lights. All other electrical devices would work - power doors, windows, radio, headlights, etc.
The onboard computer would not spit out self-diagnostic codes, and would not interface with an OBD-II code reader.
I unplugged the CPS sensor connector in the engine compartment (right side of engine as seen from the front, at the back near the last fuel injector, oval shaped with three pins). After this, the check engine light came back, I had pressure in the fuel rail and could hear the fuel pump, and the computer would generate the self-test codes telling me that I had no CPS input. The CPS is located on the driver's side of the transmission bellhousing near the top, has two bolts holding it in place, and can only be reached from underneath. Size 11mm socket and several different extension sizes are necessary depending on the size of your hands. Mine wasn't too horrible to replace.
I used an ohm meter - holding the cps sensor connector with the plastic prong on top I measured the old connector from the left pin to the middle (approx. Zero ohms), and the right pin to the middle (infinity). On the NEW CPS sensor connector I measured the pins the same way and read infinity on both readings. It seemed to me that my old CPS sensor was shorted internally, plus disconnecting it from the circuit brought my jeep partially back to life, so it seemed like I was on the right track.
I hope this info helps, my jeep started first try and no problems so far.

Do you know if your cherokee has the ability to do a self-diagnostic and spit the codes out at you using the check engine light? I have a 1996 Jeep Cherokee that will do this when I do an on/off sequence using the key, but only if your check engine light is working.
To do this, turn the ignition key ON, OFF, ON, OFF, then finally ON. (On is the position just before that extra click that starts the jeep) The check engine light will blink the number of the first code digit(count the number of flashes), then pause about 2 seconds and blink the number of the second code digit. If you have more than one error code, the light will pause about 3 or 4 seconds, then blink the first and second digits of that code the same way as before. When the computer is finished blinking "codes". It will flash 5 times, pause, then flash 5 more times to tell you that is the end of the sequence. Post back with what you find out, and someone should be able to answer with more info if you need it. GOOD LUCK!
Was this
answer
helpful?
Yes
No
Thursday, December 18th, 2008 AT 2:39 PM
Tiny
ANGIEMOORE
  • MEMBER
Ok I have fault codes 12, 11, and 54 please help
Was this
answer
helpful?
Yes
No
Thursday, December 18th, 2008 AT 3:40 PM
Tiny
ANIMALFARM
  • MEMBER
OK, here's what you have:
1. Code 11 - No crank reference signal detected during engine cranking. Could be caused by the Crankshaft Posit Sensor going bad, or by a loose connection, check plug at top rear of engine, clean, reconnect. Also follow the wires looking for broken wire. Replacing it not too bad, really. Costs approx $70.00+/-.
2. Code 12 - Direct battery input to Powertrain Control Module was disconnected within last 50 key-on cycles. OR, you disconnected the battery lately, right? Don't worry about this one, it'll go away eventually.
3. Code 54 - No fuel sync (Camshaft Signal) detected during engine cranking. There is a CAMSHAFT POSITION SENSOR, TOO! Haven't had to replace this one on mine YET, but can check on HOW and WHERE if someone else doesn't post first. Sounds like the computer is telling you it's possibly bad, also. (Having BOTH go at the same time would be WEIRD.) I'll see whar it iz, and post back, check and clean this connector, look for broken wire, too.
If cleaning doesn't work, Replace the CRANKSHAFT POSITION SENSOR first, try running the jeep, read codes again if problem still persists.
Hmmm. Camshaft Position Sensor is in the Distributor, may be referred to by some as "Stator" - There are wires that go thru the side of the distributor base through a rubber grommet, one end terminates IN the distributor as the CAMSHAFT posit sensor, other end goes to plug connector. If memory serves me correctly, this will require removing the distributor shaft to replace, henceforth requiring removal of distributor. Mechanic's job unless you're comfortable with doing the task.
Was this
answer
helpful?
Yes
No
Thursday, December 18th, 2008 AT 6:34 PM

Please login or register to post a reply.

Recommended Guides