1996 Jeep Cherokee Cluster gauges failed.

Tiny
WJHOWELL420
  • MEMBER
  • 1996 JEEP CHEROKEE
  • 4 CYL
  • 4WD
  • AUTOMATIC
  • 148,525 MILES
I have a 1996 jeep cherokee sport with about 148500 miles on it. It is in great shape it runs fine, I bought it about a month ago. At that time all the gauges and odometer worked except for the tach and spedo would bounce around. Yesterday I changed my oil and filter and later that day was driving and realized that now my spedo, tach, odometer, and fuel gauge do not work or move at all. I Checked the Fuse for it and it is fine. When I was attempting to get the oil filter off I must have knocked up against the positive on the started with my ratchet( I was using a cap wrench) and sparks flew and the started wound up. I don't think that would have anything to do with the gauges not working but they worked before that. Could there just be a loose cable behind the dash and is this a common problem? Some please help. Thanks.
Do you
have the same problem?
Yes
No
Wednesday, June 11th, 2008 AT 5:22 PM

1 Reply

Tiny
ARATAJCZ
  • MEMBER
I am having the same issue with my instrument cluster on my 1993 jeep cherokee, but mine started out of nowhere. Was wondering if you have gotten this issue fixed yet or not if so could you tell me what you did to repair it. I have replaced the instrument cluster today and that apparently was not the problem with it. If you could get back to me at aratajcz@aol. Com I would greatly appreciate it.

Tony
Was this
answer
helpful?
Yes
No
Friday, July 4th, 2008 AT 11:38 AM

Please login or register to post a reply.

Recommended Guides