Engine shuts off when it reaches operating temperature

Tiny
RAY SYMONS
  • MEMBER
  • 1995 SAAB 900
  • 2.0L
  • 4 CYL
  • 2WD
  • MANUAL
  • 182,000 MILES
When car gets to operating temperature when you take your foot off the accelerator the revs will drop off to a point where it will stall. I have replaced Idle sensor, throttle control valve, fuel pump fuel and vacuum hoses. Where do I look next?

Once it gets to operating temperature it starts hunting while I am parked.
Wednesday, February 21st, 2018 AT 8:12 PM

3 Replies

Tiny
KEN L
  • MASTER CERTIFIED MECHANIC
  • 43,461 POSTS
Hello,

This sounds like a TPS sensor has gone out is the car OBD2?

This guide can help.

https://www.2carpros.com/articles/stall-at-idle

Please let us know.

Cheers, Ken
Was this
answer
helpful?
Yes
No
Saturday, February 24th, 2018 AT 11:28 AM
Tiny
RAY SYMONS
  • MEMBER
  • 2 POSTS
The TPS The throttle body valve vacuum hoses fuel pump have all been replaced. Starts hunting once it gets to operating temperature. Then the more you drive it the worse it gets.
Was this
answer
helpful?
Yes
No
Saturday, February 24th, 2018 AT 8:04 PM
Tiny
KEN L
  • MASTER CERTIFIED MECHANIC
  • 43,461 POSTS
This sounds like a vacuum leak making the idle fluctuate can you please follow this guide to see what you find.

https://www.2carpros.com/articles/how-to-use-an-engine-vacuum-gauge

Please run down this guide and report back

Cheers, Ken
Was this
answer
helpful?
Yes
No
Monday, February 26th, 2018 AT 11:34 AM

Please login or register to post a reply.

Sponsored links