Accelerator gets stuck for a 1998 Honda Accord

Tiny
RENJITH
  • MEMBER
  • 1998 HONDA ACCORD
Hi,
Mine is a Honda Accord 1998 model (108K miles). Am facing two problems:
1. When the engine is started while the car is cold, the accelerator revvs up. And at this time, if you try to press the accelerator, it gets stuck and as a result, you need to apply more pressure to it. And while driving, the same behaviour is observed sometimes (need for applying more pressure to the accelerator). One exemption to the above scenario is that if you make the engine more warm, then the problem is not observed much.
2. When I apply brakes, some noise is heard from the Engine part. (Some tik tik sound which is a bit loud is heard).
Thanks in advance for the help and I really am in need of a help.
Do you
have the same problem?
Yes
No
Friday, November 16th, 2007 AT 3:47 PM

2 Replies

Tiny
MERLIN2021
  • EXPERT
If the check engine light is not on check the cable, possible fray inside the jacket. Disconnect it from the throttle with the engine off, then see if the throttle operates smoothly without the cable attached, if not replace the throttle, if it does work OK, replace the cable!
Was this
answer
helpful?
Yes
No
Friday, November 16th, 2007 AT 4:38 PM
Tiny
RENJITH
  • MEMBER
Cool.. Thanks a lot. The Engine light is not lit till now. So will check as you had mentioned.
Thanks once again
Was this
answer
helpful?
Yes
No
Friday, November 16th, 2007 AT 4:55 PM

Please login or register to post a reply.

Recommended Guides