1996 GMC Sierra No Cold Start

Tiny
BERNDOG5
  • MEMBER
  • 1996 GMC SIERRA
  • V8
  • 4WD
  • AUTOMATIC
  • 170,000 MILES
I have a problem with a no cold start on my truck. When the engine temp is below freezing it will not start it will just turn over. I may get the occasional engine fire and a short ignition but it will stop immediately then just crank. When the temp is warm no problems starting. I believe it may the the coolant temp sensor that is faulty. Can you give me any input or suggestions if I am heading in the right direction?
Thank much apprediated and fantastic site.
Do you
have the same problem?
Yes
No
Wednesday, November 12th, 2008 AT 11:41 PM

3 Replies

Tiny
RASMATAZ
  • MEMBER
The coolant temperature sensor jobs is to tell the computer that the engine is cold and need more fuel-replace it and see what happens-its like the choke on a Carb system-that gives fuel during initial cold starts-
Was this
answer
helpful?
Yes
No
Thursday, November 13th, 2008 AT 4:04 AM
Tiny
BERNDOG5
  • MEMBER
I replaced the sensor and still the same problem. I tested the line running into the sensor with a circuit tester and could get no sign of anything on either connector. When should the power start running through this line? Any further advice?
Was this
answer
helpful?
Yes
No
Sunday, November 16th, 2008 AT 11:32 PM
Tiny
RASMATAZ
  • MEMBER
Turn ignition switch to run then check the 5volts reference on the yelow and black wire


http://www.2carpros.com/forum/automotive_pictures/12900_cts_20.jpg




http://www.2carpros.com/forum/automotive_pictures/12900_cts1_4.jpg

Was this
answer
helpful?
Yes
No
Monday, November 17th, 2008 AT 1:29 AM

Please login or register to post a reply.

Recommended Guides