1996 GMC C1500 wont start

  • 1996 GMC C1500

Electrical problem
1996 GMC C1500 V8 Four Wheel Drive Automatic 200, 00 miles

my truck wont start
fule pump wroks
i changed the vcm because a deler said that if didnt have check engen light that it was gon
after changing it I got the truck to start and ran it for two hr. Shut it off wont start again I had no dash lights again and their wasnt any power to 3 fuses 10 amp and two 20 anmp fuses so I put ajumper from the bat. To the pink feed wire on the coil and this back feed to those fuses and the I had dash display again still wont start so with that I left the jumper in line and unpluged the crank sensor then pluged it back in then I heard the fule pump relay come on so the crank sensor works and I have fule so I removed the jumper wire went and got a code reader pluged in in and turned they on and it came up as no link so I put the jumper back on and pluged the code reader in and it said one code found P1351 witch is ignition coil voltage to high so I that that was because I was feeding it off the bat. Soi went and bought a inghtion switch harness and instaled it now I have dash light displays but the truck wont start and I have power on those fuses that didnt have before and the fule relay come but the truck wont start what is going on here will verifi that I have power at the distributor and fire to the plugs to day

Do you
have the same problem?
Wednesday, January 7th, 2009 AT 5:58 AM

1 Reply


Yep, start basic and see if you have spark out of the coil first, if so then see if you have it at the plugs. If it has spark try shooting a little carb cleaner into the intake and see if it starts, if it does, this is a fuel problem. Then verify good pressure even though pump is running. If pressure is good, you may have aproblem of no injector pulse. Clear the codes too and see if anything else comes up while testing

Was this
Friday, January 9th, 2009 AT 3:58 PM

Please login or register to post a reply.

Recommended Guides