1997 Geo Metro wont start

Tiny
A GROOM
  • MEMBER
  • 1997 GEO METRO
Engine Mechanical problem
1997 Geo Metro 4 cyl Four Wheel Drive Automatic

We recently had to take it to get "fixed" cause the engine was stalling it would go and then shut off all of a sudden. Any way we changed the o2 sensor and the ffuel pump being thats what we were told the problem was. Now the car wont even start at all! We turn the ignition key and it will make an effort but wont fully go through. Im thinking it might be the ignition coil or maybe the spark plugs dunno but would like some insight. Thanks
Do you
have the same problem?
Yes
No
Tuesday, May 18th, 2010 AT 10:24 AM

2 Replies

Tiny
RASMATAZ
  • MEMBER
Lets do below for a start to determine if its fuel or spark related issue and get back asap.

Get a helper disconnect a sparkplug wire or 2 and ground it to the engine atleast 3/16 away from ground-have helper crank engine over-do you have a snapping blue spark? If so-you have a fuel related problem, check the fuel pressure to rule out the fuel filter/fuel pump/pressure regulator and listen to the injector/s are they pulsing or hook up a noid light. No snapping blue spark continue to troubleshoot the ignition system-power input to the coil/coil packs, coil's resistances, distributor pick-up coil, ignition control module, cam and crank sensors and computer Note: If it doesn't apply disregard it
Was this
answer
helpful?
Yes
No
Friday, May 21st, 2010 AT 9:24 PM
Tiny
DJCARSON
  • MEMBER
I had the same problem once. I finally narrowed it down to the wire harness to the fuel injector. The ohm reading wasnt correct. It turns out there is a recall on that harness, but its not available anymore. I was able to wiggle the harness until I got the right reading listed in the haynes book and it worked perfect once again. I found a couple places on the internet that listed the harness p/n, but never checked to see if it was the right part. Eventually, I want to try and find one. They are about $50 bucks if you can find one.

One other time the car wouldn't start while it was hot. Then it just started dying on me while I was driving. Turned out to be a bad fuel injector. Bought a rebuilt for $140 at kraiger auto and popped it in. Took about minutes worked great again. Later a found rebuilt fuel injector for this car on amazon. Com for $42.00. Exact rebuilt injector for about $100 less.

Good luck.
Was this
answer
helpful?
Yes
No
+1
Friday, June 18th, 2010 AT 9:54 PM

Please login or register to post a reply.

Recommended Guides