Temperature gauge and oil gauge and going all the way to the red soon as I start the engine

Tiny
GINGER KING
  • MEMBER
  • 1997 FORD F-150
  • 4.2L
  • V6
  • 2WD
  • AUTOMATIC
  • 250,000 MILES
After running for 5 minutes the oil gauge goes down to about normal but temperature gauge stays in the red. Top radiator hose gets hot, bottom radiator hose is still cold and water in the reservoir is still cold. I just recently replaced both heads, water pump, thermostat and serpentine belt. Please help.
Do you
have the same problem?
Yes
No
Wednesday, July 29th, 2020 AT 4:44 PM

4 Replies

Tiny
ASEMASTER6371
  • EXPERT
Good evening,

The engine is overheating.

https://www.2carpros.com/articles/engine-overheating-or-running-hot

It may be air bound. I would remove the thermostat and fill the system until the coolant comes out the thermostat housing. Then install the thermostat and top it off and run it.

https://www.2carpros.com/articles/replace-thermostat

Roy

Was this
answer
helpful?
Yes
No
Wednesday, July 29th, 2020 AT 5:49 PM
Tiny
BMDOUBLE
  • EXPERT
If you have a compressor, the best way to fill these is with an airlift. They can be bought online for around $40.00. I can tell you that it's worth it!
Was this
answer
helpful?
Yes
No
Thursday, July 30th, 2020 AT 10:03 AM
Tiny
GINGER KING
  • MEMBER
Thank you, I will try this.
Was this
answer
helpful?
Yes
No
Saturday, August 1st, 2020 AT 11:29 AM
Tiny
KEN
  • ADMIN
ASEMASTER6371 and BMDOUBLE are some of our best! Please let us know what you find. We are interested to see what it is.
Was this
answer
helpful?
Yes
No
Saturday, August 1st, 2020 AT 11:30 AM

Please login or register to post a reply.

Sponsored links