Front right turn signal not working?

Tiny
MILESWEST
  • MEMBER
  • 2004 GMC ENVOY
  • 6 CYL
  • AUTOMATIC
  • 200,000 MILES
The front right turn signal just doesn't seem to work, however the back right turn signal works fine. Took it to an auto shop and changed the bulb, however there was still no blinking light when I'd use my turn signal, even changed our a fuse with no change in progress. Most notably, the park lights work, but that front light will not blink when using a turn signal, nor the hazards. I don't know what the issue could be, possibly a faulty wire?
Do you
have the same problem?
Yes
No
Monday, November 28th, 2022 AT 3:21 PM

1 Reply

Tiny
JACOBANDNICKOLAS
  • EXPERT
Hi,

Oftentimes, the light socket fails. When you use the right signal, does it flash quicker than normal?

The first thing to check is for power. All you need is a test light. At the lamp assembly, locate the dark blue wire to the bulbs. Turn the signals on so the rear is flashing and with a test lamp, see if the dark blue wire gets power. It should blink like the signal.

If there is power, then suspect an issue with the light socket.

If there is no power, we need to trace that wire back to the signal fuse. We know the fuse is good because the rear works. However, there is a separate wire to power the front. There could be a connection issue with that wire.

Let me know what you find. Also, here is a link you may find helpful:

https://www.2carpros.com/articles/how-to-use-a-test-light-circuit-tester

I attached the schematic to the front signal below.

Take care,

Joe

See pic below.
Was this
answer
helpful?
Yes
No
Monday, November 28th, 2022 AT 9:41 PM

Please login or register to post a reply.

Sponsored links